digiKam dependencies

digiKam requires a lot of libraries. So, before compiling yourself digiKam, you'll have to download and install them.

To get an up to date list, check these files: digiKam README and Kipi-plugins README.

If you are using a distribution based on apt-get (Ubuntu, debian, ...), an easy way to install the dependencies is to use the commands:
sudo apt-get build-dep digikam
sudo apt-get build-dep kipi-plugins
Note that this method will provide the dependencies of the packaged version of Digikam, current svn version may contain more dependencies.

Here's a partial list :

  • libjasper :
    download it
    Don't forget to configure it with --enable-shared