digiKam 1.0.0-beta1 released...

Dear all digiKam fans and users!

A new test cycle has been started to complete 1.0.0 release...

pgfsupportindigikam

digiKam tarball can be downloaded from SourceForge at this url

digiKam will be also available for Windows. Precompiled packages can be downloaded with KDE-Windows installer. See KDE-Windows project for details.

See below the list of new features and bugs-fix coming with this release:

NEW FEATURES (since 0.10.x series):

General : Add new Batch Queue Manager.
General : New tool bar animation banner.
General : Fix compilation under MSVC 9.
General : New first run assistant.
General : New dialog to show Database statistics.
General : Add support of wavelets image file format PGF.

AlbumGui : Icon view is now based on pure Qt4 model/view.
AlbumGui : New overlay button over icon view items to perform lossless rotations.

ImageEditor : New Liquid Rescale tool.

CameraGUI : New history of camera actions processed.

BUGFIXES FROM KDE BUGZILLA (alias B.K.O | http://bugs.kde.org):
001 ==> 091742 : Batch process auto levels.
002 ==> 149361 : Not all edit actions are available as batch commands (for example auto-levels and gamma correction).
003 ==> 187523 : digiKam crashes on startup (undefined symbol).
004 ==> 187569 : Crash on star removing when filtering by stars.
005 ==> 186549 : digiKam crashes when hovering the bottom part of its.
006 ==> 187641 : Error while loading shared libraries: libkdcraw.so.5.
007 ==> 187429 : Crash on Launch after disable KIPI plugins rotate.
008 ==> 187937 : Writing tags to files doesn't update modification timestamp.
009 ==> 184687 : Crash after deleting an empty album.
010 ==> 186766 : Crash after finish resize and rename of images in folder.
011 ==> 184953 : Zooming and paning in slideshow / without toolbars.
012 ==> 187508 : Spontaneous crash whilst doing nothing in particular.
013 ==> 188235 : Assigning a color profile to TIFF images does not work anymore with 0.10.0.
014 ==> 187748 : Install application icons to right path for non-KDE desktops.
015 ==> 186255 : digiKam crashes when switching collection database.
016 ==> 178292 : AspectRatioCrop is slow and jumps around in first second.
017 ==> 181892 : AspectRatioCrop: some properties should be disabled.
018 ==> 188573 : RW2 converter broken for low light images.
019 ==> 188642 : GPS data in Digikam shows the wrong places on the map.
020 ==> 188907 : Album view should display subfolders, like tag view does.
021 ==> 183038 : "Select All" action interrupts other widgets.
022 ==> 189022 : Better guessing of proportions with 'inverse transformation' option.
023 ==> 189286 : EXIF info lost while converting from NEF to TIFF.
024 ==> 189336 : Preview of RAW look different than actual image.
025 ==> 189413 : Images without GPS-data are shown on the equator in the geolocation-view.
026 ==> 184954 : Unable to delete items from camera - canon sx10is.
027 ==> 189168 : You do not have write access to your home directory base path.
028 ==> 185617 : Images are invalid / not found when an album is moved.
029 ==> 187265 : Advanced search crashes if a selected album has been deleted.
030 ==> 185177 : Searches are not updated when changes are made to the resulting image set.
031 ==> 189542 : Crash on opening download dialog.
032 ==> 114225 : Free rotation using an horizontal line.
033 ==> 189843 : Crash on ubuntu jaunty beta.
034 ==> 167836 : Image preview is too large.
035 ==> 189250 : Editing a canon camera jpeg adds broken sRGB profile.
036 ==> 187733 : Cannot turn off sidebar after Infrared filter usage ?
037 ==> 188755 : Strange behaviour on selection.
038 ==> 185884 : Empty view after clicking the left thumbnail image in Image Editor filter view.
039 ==> 188062 : Synchronize Images with Database does not save Copyright, Credit, Source, By-line, By-line Title in IPTC.
040 ==> 186823 : Several bugs in lens defect auto-correction plugin.
041 ==> 190612 : digiKam and Showfoto crash.
042 ==> 191092 : No images shown in digiKam albums.
043 ==> 191203 : digiKam crashed on first load, after being installed on ubuntu 9.04.
044 ==> 151321 : Remaining space incorrectly calculated when using symlinks (import from camera).
045 ==> 189742 : Thumbnails not saved between sessions.
046 ==> 180507 : Crash when dragging picture to another app with kwin_composite enabled.
047 ==> 190296 : Can not save images on Windows.
048 ==> 141240 : Camera download: file rename with regexps.
049 ==> 181951 : digiKam crashes (SIGABRT) during the importing of pictures from Kodak V530 camera.
050 ==> 166392 : File-Renaming: custom sequence-number doesn't work.
051 ==> 182332 : Can't stop generating of thumbnails when import from a card reader.
052 ==> 152382 : Unable to view photo.
053 ==> 161744 : Filenames are lower case when imported via sd card reader, upper case when imported via usb cable directly from camera.
054 ==> 187560 : Iptc data for author are missing while downloading images.
055 ==> 192294 : digiKam crash when i try to import photos from my card reader.
056 ==> 192413 : Missing items from right-click search menu.
057 ==> 131551 : Camera port info deleted when editing camera title.
058 ==> 181726 : digiKam collect video, music when I connect usb key.
059 ==> 154626 : Autodetect starting number for "appending numbers" when downloading images.
060 ==> 188316 : Missing NEF files when importing from USB disk.
061 ==> 193163 : digiKam ignores settings on the rating stars.
062 ==> 189168 : You do not have write access to your home directory base path.
063 ==> 193226 : Data loss on downloading photos from camera.
064 ==> 189460 : digiKam crash when goelocating image in the marble tab.
065 ==> 186046 : Crash after calling settings.
066 ==> 193348 : Can't build digiKam on kde 4.2.3.
067 ==> 150072 : Download with digiKam doesn't work with the first start of digiKam.
068 ==> 193738 : Have the image editor status bar show the current color depth.
069 ==> 191678 : Exif rotation for Pentax Pef not working.
070 ==> 146455 : Image rotation and auto-rotate don't work.
071 ==> 152877 : Thumbnails: URI does not follow Thumbnail Managing Standard.
072 ==> 140615 : Pre-Creating of image thumbnails in whole digiKam/all subfolders.
073 ==> 193967 : VERY fast loading of thumbnails [PATCH].
074 ==> 191492 : digiKam hangs on startup "reading database".
075 ==> 171950 : Lost pictures after 'download/delete all' when target dir had same file names.
076 ==> 191774 : digiKam download sorting slow, and wrong with multiple folders.
077 ==> 191842 : digiKam download forgets to download some pictures (multiple big folders).
078 ==> 187902 : Status bar gives wrong picture filename and position in list after "Save As".
079 ==> 193894 : Pop up "Copy Finished!" dialogue when done downloading from camera.
080 ==> 193870 : digiKam freezes after second exif rotation on same file.
081 ==> 194342 : What is the right rename pattern to get names like 2009.02.18_09h56m30s ?
082 ==> 194177 : digiKam crashes always on startup and causes signal 11 (SIGSEGSV) - app not useable.
083 ==> 169213 : digiKam should not enter new album after creating it.
084 ==> 191634 : Statistics of the database, and all pictures ?
085 ==> 193228 : Experimental option "write metadata to RAW files" corrupts Nikon NEFs.
086 ==> 194116 : digiKam crashed for no obvious reason.
087 ==> 179766 : Auto crop does not fully remove black corners created by free rotation.
088 ==> 134308 : Add arrow buttons on thumbnail to perform lossless rotation.
089 ==> 194804 : Tag, rate, rotate and delete via slideshow.
090 ==> 192425 : Star rating setting under thumbnails is a nuisance.
091 ==> 194330 : digiKam crashed when deleting image.
092 ==> 188959 : On first use, digiKam should not scan for images without user confirmation.
093 ==> 195202 : Thumbnail rename fails (cross-device link) and so cache doesn't work.
094 ==> 161749 : Raw Converter needs more options.
095 ==> 150598 : File rename during image upload fails silently.
096 ==> 161865 : Image not placed in New Tag category.
097 ==> 136897 : THM files are not uploaded.
098 ==> 195494 : Deleting and cancelling a picture with the keyboard still delete the picture.
099 ==> 120994 : Print preview generates HUGE postscript files.
100 ==> 191633 : Rename a folder, press F5 and see thumbnails go away.
101 ==> 195565 : Loading next image while in curves tool does not confirm and loads nothing.
102 ==> 189046 : digiKam crashes finding duplicates in fingerprints.
103 ==> 185726 : SIGSERV 11 by choosing an image for fullscreen.
104 ==> 193616 : Location not shown digiKam right sidebar after geolocating in external program.

Nepomuk

First of all, congratulations for this very important release! it's nice to see that you have finally reached 1.0 status :)

One question: Is there any kind of Nepomuk support? Is it going to be support for it in the future?

Planed...

This week end, Marcel go to this coding sprint... to code a Nepomuk interface for digiKam...

Nepomuk interface for digiKam done...

Look this message from Marcel...

Congratulation

Congratulations for this release, I'm always very impressed when I read the tons of bugfixes !!

im using this version under

im using this version under kde4.3beta2 and take a lot of time to load the images from a album, and in the 0.10 version was really fast.

solved, just deleted the old

solved, just deleted the old config and now works fast like 0.10.x

Hmm this is weird, don't see

Hmm this is weird, don't see the connection here. But well if it helped :-)

Andi

im using this version under

im using this version under kde4.3beta2 and take a lot of time to load the images from a album, and in the 0.10 version was really fast.

Gilles, this could be related

Gilles,

this could be related to the thumbsDB. I experience the same behavior, 1.0.0 is way slower then 0.10 as I mentioned before.

Andi

digiKam rocks !!!

that's an impressive list.... :)
Thanks a lot for your work for continuosly improving the software....

Congratulations and thank you

Congratulations and thank you for this release. It looks great :)

Problems compiling kipi-plugins-0.3.0 for digikam-1.0.0-beta1

I have a debian/lenny system with the KDE 4.1 libraries,
and have manually installed LibRaw-0.7.2 and exiv2-0.18.1 under /usr/local

running cmake . in the kipi-plugins-0.3.0 does not find these libraries (only the original lenny ones), however with
cmake -DKEXIV2_INCLUDE_DIR=/usr/local/include/exiv2 -DKEXIV2_LIBRARIES=/usr/local/lib \
-DKDCRAW_INCLUDE_DIR=/usr/local/include -DKDCRAW_LIBRARIES=/usr/local/lib .

I still get the error

-- Found Qt-Version 4.4.3 (using /usr/bin/qmake-qt4)
-- Found X11: /usr/lib/libX11.so
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Found KDE 4.1 include dir: /usr/include
-- Found KDE 4.1 library dir: /usr/lib
-- Found KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found Kexiv2 library in cache: /usr/local/lib
-- Found Kdcraw library in cache: /usr/local/lib
-- Check Kipi library in local sub-folder...
-- Check Kipi library using pkg-config...
-- Found libkipi release < 0.2.0, too old
CMake Error at /usr/share/kde4/apps/cmake/modules/FindKipi.cmake:85 (message):
Could NOT find libkipi header files
Call Stack (most recent call first):
CMakeLists.txt:39 (FIND_PACKAGE)

What is strange is that cmake does not recognise that it is run from inside the kipi-plugins-0.3.0 directory and that there is a line
FIND_PACKAGE(Kipi REQUIRED)
in the kipi-plugins-0.3.0/CMakeLists.txt file; when I comment out this line and rerun with
cmake -DKIPI_FOUND=1 .
The generation of the build files completes.

However when I then run make, I get the error

[ 0%] Generating common/libkipiplugins/svnversion.h
[ 0%] Built target kipiplugins-svnversion
Generating batchprogressdialog.moc
Generating imageslist.moc
Generating imagedialog.moc
[ 0%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kipiplugins_automoc.o
[ 0%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpaboutdata.o
[ 0%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpwriteimage.o
In file included from /home/ossi/Apps/digikam-1.0.0-beta1/LIBS/kipi-plugins-0.3.0/common/libkipiplugins/kpwriteimage.cpp:52:
/home/ossi/Apps/digikam-1.0.0-beta1/LIBS/kipi-plugins-0.3.0/common/libkipiplugins/kpwriteimage.h:51:43: error: libkdcraw/rawdecodingsettings.h: No such file or directory
/home/ossi/Apps/digikam-1.0.0-beta1/LIBS/kipi-plugins-0.3.0/common/libkipiplugins/kpwriteimage.h:55:30: error: libkexiv2/kexiv2.h: No such file or directory
.....

However the files rawdecodingsettings.h and kexiv2.h are nowhere to be found in LibRaw-0.7.2 and exiv2-0.18.1

At the moment I am lost as I am completely new to the cmake environment. Any ideas on how I should proceed?

Regards, Oswald

Installed 1.0.0-beta1 from debian/unstable

After copying my root partition to another HD and - with fingers crossed - upgraded digicam from the debian/unstable repository together with a load of kde4 and other libraries.

Fortunately the upgrade went smoothly, and digikam 1.0.0-beta1 started without problems, sucessfully migrating my 0.9.x meta-tags to the version 4 database.

Now I can plug my album+database USB harddrive also into my Kubuntu laptop (currently still digikam 0.10.0) and process the fotos there.

Great Job!

can I have root album on

can I have root album on FTP??

dolphin say: the directory is not exist, or is nor readable, but directory exist and is rewritabe, readable :)

or please add "export to FTP"

or please add "export to FTP" to "export" - might be good

use the force luke

You can add a collection located on a network share : go to settings -> configure digikam. I think if you manage your ftp folder this way, it's much more flexible.

PPA for Kubuntu?

Is there a ppa for Kubuntu somewhere that I can add so I get this release?

Does it support marble 0.8svn

Does it support marble 0.8svn (from kde 4.3.0 beta2)? I'm asking because the only way i could run digikam 1.0.0 beta 1 is when i disable marble support in compiling (-DENABLE_MARBLEWIDGET=no -DWITH_MarbleWidget=no).

Impressive Progress

I upgraded to KDE 4 last month and was dismayed at the large number
of applications that have taken many steps backwards in the transition.
DigiKam is one of the few that I use regularly that has maintained all
of its functionality and added some nice new features. You deserve a
lot of praise for not following the crowd, rewriting everything from
scratch and leaving your users disappointed.

I look forward to the new releases and I'm sure that your approach of
improving things incrementally will continue to delight your growing
user base.

Many thanks

Thanks a lots for this comment. It's really digiKam team approach : no feature regressions...

I want to support to 100% to

I want to support to 100% to that comment. Digikam did the KDE4-port really well.

Congratz and Thanks

I am really impressed about the good progress this application has made.

It's not only the app. There is a good documentation (for installung/compiling too), a nice website and a transparent developing process.

It just feels...

Professional

and... I like that new Batch

and... I like that new Batch Queue Manager. Really good work.

Crashes on delete and move pictures

I installed 1.0.0-beta1 from debian/unstable (sidux) and encounter some crashes (not always) while deleting and moving an amount of mails (30 to 100) between my albums. After starting digikam again the delete/move proceeded sometimes half and sometimes to it end.

I install gdb and digikam-dbg now to create some backtrace. I'm using digikam since 0.9.x and 0.10.x.

Great work anyway.

added to bugs.kde.org

Here's my bug-report about this crash.

Good luck
Chrisch

Fixed in svn

Fixed in svn (see duplicate in bug-report)
Thanks and Regards,
Chrisch

http://www.erreauk.com

I installed 1.0.0-beta1 from debian/unstable (sidux) and encounter some crashes (not always) while deleting and moving an amount of mails (30 to 100) between my albums. After starting digikam again the delete/move proceeded sometimes half and sometimes to it end.

erreauk

manual sorting in icon view?

Hi, love your app!

However, one thing is missing in my point if view, an ability to do manual sorting. I need that feature to sort photos from multiple sources (different cameras), before renaming them and sending them to my website for online viewing.

This feature is missing from all linux photo-management apps, but present in similar windows apps such as ACDSee and FastStone Image Viewer

Does the new icon view make this easier to implement?
Thanks!

Sharpen tool

Hello,
I can't find "sharpen tool" :-(( it was in menu enhance but now is there "only" brightnes/... , hotpixels, in-paiting, lens, noise reduction, restoration. I have gentoo with kipi 0.4, Digikam from SVN (revision 990984) - but I can't find sharpen tool so in some older versions. Do you know where to look for a mistake, please? in compiling (useflags) or in other packages which provides this feature...or...? Thanks a lot!

BTW: Digikam is GREAT! :-)

broken packages.

Nothing have been removed. Sharpen tool is always at the same place.

thank for super-quick

thank for super-quick answer!
I understand that you can't know all packages from all the linux distributions - but please, try advise me, what packages (projects) may be it.

No idea...

Well, compile yourself digiKam (:=)))...

I have self-compiled digikam

I have self-compiled digikam - without problems and warnings. I have compiled Digikam under instruction in section "download" > svn (kde4)

start digiKam with a new user

create new account, and start digiKam. setup all properly, and look if Sharpen tool is there...

i have created new user named

i have created new user named "test", configured startup wizzard in Digikam, but with sharpen tool no changes - missing :-(

strange...

Sharpen tool come from with core editor image plugin. This one include Blur, Red Eyes, BCG, BW, HSL, Ratio crop, etc... Do you see these options in editor ?

I don't see it, where exactly

I don't see it, where exactly should be - in the menu?
color:curves adj.,levels adj.,channel mixer,color effects,white balance.
enhance: hot pixels, inpainting,lens,noise reduction,restoration.
transform: rotate L/R,Flip H/V,Crop,Liquid rescale,free rotation,perspective adj.,shear.
decorate: add border,insert text,templ.superimpose,apply texture
filters: blur effects, charcoal drawing,distortion effects,emboss,add film grain,IR film,Oil paint,raindrops

BTW: I have a friend with other distro (Arch linux) and he has the same problem

Core pluging is not installed...

It's clear : image editor core plugin is not complied and installed. I don't know why...

In fact code is there

When you compile digiKam, check if this dir is compiled.

OK, you have right :-)

OK, you have right :-) Tomorrow i check the compilation process, today I am tired... Thank you for your time VERY much!

Hi, i'm back :-) So i

Hi,
i'm back :-) So i recompiled digiKam - here is the log file. Coreplugins are compiled and installed, sharpen tool too :-(

the log is uploaded also here

the log is uploaded also here (Previous link is to the czech server without english interface for download - i'm sorry)