Merry Christmas Again : Kipi-plugins 1.0.0 is there...

Merry Christmas digiKam fans and users!

In the spirit of the season, we bring you a nice gift to put under your white Christmas tree:

digiKam team is proud to announce Kipi-plugins 1.0.0 !

melting_the_ice-final_1024

kipi-plugins tarball can be downloaded from SourceForge at this url

Kipi-plugins will be also available for Windows. Precompiled packages can be donwloaded with KDE-Windows installer. See KDE-Windows project for details.

See below the list of new features and bugs-fix coming with this release:

001 ==> GPSSync : 199189 : GPS correlator does not allow offset in seconds.
002 ==> GPSSync : 165277 : Last gpx directory isn't remembered.
003 ==> GPSSync : 174086 : GPX time parsing problems.
004 ==> PicasaWebExport : 162993 : picasa album list not refreshed.
005 ==> Facebook : 202045 : Facebook exports always to same album (the one initially selected).
006 ==> GPSSync : 217710 : GPSSync unable to modify coordinates.
007 ==> GPSSync : 217989 : GPSSync randomly no satellite view.
008 ==> DNGConverter : 217897 : DNGconverter produces invalid DNG files.
009 ==> Libkdcraw : 218762 : Libraw is too old.
010 ==> Common : 219207 : Compilation error in PreviewWidget.
011 ==> GPSSync : 192439 : Geolocation position not remembered or initialised consistently.

Compiling fails for me with

Compiling fails for me with "class KSaneIface::KSaneWidget’ has no member named ‘closeDevice’" in acquireimages/scandialog.cpp
void ScanDialog::closeEvent(QCloseEvent *e)
{
d->saneWidget->closeDevice();
saveSettings();
e->accept();
}
I have found this commit, so I ask it is alright to revert that line to d->saneWidget->scanCancel(); ?

this due to use libksane from trunk API

this call use libksane API from trunk.

and there is no libksane CMake rules to control version available to compile.

Gilles Caulier

:(

So, no kipi-plugins 1.0.0 with KDE 4.2?

yes, I will fix it...

yes, I will fix it...

So is there an patch to make

So is there an patch to make it compile on KDE4.2 ?
If so please link to it.

It compile fine with KDE 4.3.x

Just tested. It compile with libksane from KDE 4.3.x

comment line is enough... but...

For KDE 4.2, commenting line d->saneWidget->closeDevice() is fine... but...

I trying to do it automatically in code, checking libksane version ID from libksane/version.h... But it doesn't exist (as in libkipi, libkexiv2, libkdcraw... etc...)...

It's a bug in libksane. Please report it to KDE bugzilla...

libksane version macro

I have now added the version macro to trunk. I have used the KDE version macro to check the libksane versions.

trunk only ?

Do you have patched libksane for KDE4.3 and 4.2 too ?

Groovy! Looks like GPSsync

Groovy! Looks like GPSsync has gotten some love. :) I love the way KIPI integrates between Digikam and Gwenview. So fast and easy. I've been trying to get Krita devs to look into KIPI, but Krita supports 32bit images. Any chance of KIPI supporting 32 bit some time in the future?

Either way, thanks for working on these. I love my KIPI plugins. It keeps amusing me how Gwenview can already do everything the Ubuntu team is looking for in a photo previewing and basic editing app to replace Gimp. Maybe they should start looking outside Gnome... ;-)

I'll stop creating trouble now... (maybe)

agreed

Hahaha agreed!

Kubuntu packages

I wonder when kipi-plugins will be packaged in kubuntu-ppa backports or backports-beta repositories.
I've upgraded digiKam to 1.0 RC from backports-beta with KDE 4.4 Beta 2 but because of dependency problems this upgrade removed kipi-plugins package.