kipi-plugins 1.1.0 released...

Dear all digiKam fans and users!

digiKam team is proud to announce Kipi-plugins 1.1.0 !

Exposure Blending Plugin at Work

kipi-plugins tarball can be downloaded from SourceForge at this url

Kipi-plugins will be also available for Windows. Precompiled packages can be donwloaded with KDE-Windows installer. See KDE-Windows project for details.

See below the list of new features and bugs-fix coming with this release:

NEW FEATURES:

ExpoBlending : New tool to make pseudo HDR image with a stack of bracketed images.
PrintAssistant : New custom grid layout.
PrintAssistant : Filling page with custom size images.

BUGFIXES FROM KDE BUGZILLA:

001 ==> ExpoBlending : 144593 : New High Dynamic Range (HDR) plugin.
002 ==> GalleyExport : 219998 : Export to Gallery plugin crashes when adding files.
003 ==> AdvancedSlideShow : 215798 : Slideshow crashes when starting.
004 ==> JPEGLossLess : 200031 : Photo is rotated but not thumbnail.
005 ==> PicasaWebExport : 199145 : Tags not exported to picasaweb [patch].
006 ==> PicasaWebExport : 215846 : PicasaWeb plugin crashes digiKam after start sending the pic [delete, KIPIPicasawebExportPlugin::PicasawebWindow::slotUploadImages] (double deletion).
007 ==> ExpoBlending : 221056 : Expoblending.app causes digiKam compile to fail.
008 ==> PicasaWebExport : 205903 : accentuated chars are converted into a mess during picasa web export [patch].
009 ==> PicasaWebExport : 220433 : digiKam crash when has long time working on it.
010 ==> PicasaWebExport : 208426 : Exporting images fails with : "Could not connect to host xxxx.xxxx.xxxx.xxxx: Unknown error.".
011 ==> ExpoBlending : 222297 : Overwriting on Windows and multiple saves fixes [patch].
012 ==> PicasaWebExport : 198045 : New albums don't appear in list.
013 ==> PicasaWebExport : 200469 : Ampersand character in caption causes Picasa export to freeze.
014 ==> JPEGLossLess : 222328 : In-place rotation converts 16 bit TIFF to 8 bit.
015 ==> PrintAssistant : 219381 : fill page with images of certain size.
016 ==> HTMLExport : 194946 : Simple Fix - extra " ' " in cleanframes/themes/template.xsl.
017 ==> GPSSync : 182326 : Remember last position when geotagging images.
018 ==> GPSSync : 165613 : Crash when GPS altitude is negative.
019 ==> GPSSync : 167286 : GPS tagging fails with message titled "digikam3rdparty.free.fr" and text "unauthorized call of the API" when starting the gps tagger window.
020 ==> GPSSync : 224205 : Geolocation correlator: GPX date/time format.
021 ==> GPSSync : 222067 : GPSSync no more search field to fill with a town.
022 ==> AdvancedSlideShow : 224379 : digiKam doesn't compile (problem with advanced slideshow).

Thanks one more time!! Are

Thanks one more time!!
Are they passed on the repository? Update manager did not find any updates on Kipi yet.........

This is not how it works, it

This is not how it works, it can take a weeks or even month for your distro maintainers to put this release on repos.

You need to ask from

You need to ask from distributors who packages your distribution. Most distributors pick ups these on their next release.

pseudo?

what do you mean by 'pseudo HDR image'?

This is about the algorithm

This is about the algorithm that is used to create the image. The normal "HDR" workflow means to 1. create an image (from several differently exposed source images) with a much higher color depth then a usual image and what can be displayed by a normal monitor etc. 2. this image is mapped onto an image with the normal 8 or 16 bit color depth with an algorithm that produces images that are nice to view. So the main idea is that you first create an image with much more color depth for reducing this later in a way that makes the result nice.

The way enfuse goes, which is wrapped by the new plugin, is different in the way that it doesn't create such an intermediate high-depth image but instead blends the source images directly all done in the original color depth limits.

Thanks

Another big thank you for the hard work and time of the team!

www.kipi-plugins.org

you might want to update that site?
thanks!

Great work on the new

Great work on the new plugins!

I was really looking forward to try the new expoblending tool, couldn't get it to compile on 64bit kubuntu karmic though. Hugin 0.8, Enblend 3.2 and libgomp are installed - any ideas?

cheers Michael

look libkdcraw

It require libkdcraw from KDE 4.4. take a look in README file for details

Gilles Caulier

Compile help: digkam with kipi plugins 1.1.0 on debian/lenny

The debian/lenny digikam is quite out-of-date, so I tried to compile and install the latest digikam under /usr/local

1. ) uninstalled debian digikam and kipi-plugins

2.) compiled & installed kipi-plugins 1.1.0 with
cmake -DCMAKE_BUILD_TYPE=debugfull DCMAKE_INSTALL_PREFIX=/usr/local .
make ; sudo make install

3.) compiled & installed digikam 1.1.0 with
export CMAKE_MODULE_PATH=/usr/local/lib/kde4/
export CMAKE_PREFIX_PATH=/usr/local
cmake -DCMAKE_BUILD_TYPE=debugfull DCMAKE_INSTALL_PREFIX=/usr/local .
make ; sudo make install
4.) digikam starts OK, but there are no plugins

The freshly compiled kipiplugin_advancedslideshow.so, etc. and the digikamimageplugin_freerotation.so, etc. are in /usr/local/lib/kde4/
There is a fresh /usr/local/lib/libkipiplugins.so.1.0.0

However there is also an old /usr/lib/libkipi.so.6 that belongs to a debian package libkipi6

Any help is very much appreciated

Oswald

Any luck on this..

Any luck on this..

I commented out line 349 in cmake list as advanced advanced slideshow keeps throwing a syntax error.

Digikam compiles okay and runs on kde 4.4.x or whatever it is...

Kipi complies okay..

All appears well but when dk starts there are no kipi plugins...

I am lost..

Any luck on this..

I had similar problems which I solved by installing Kipi in /usr instead of /usr/local.

I believe the problem to be that all KDE 4 components need to be in the same place, so unless you have compiled the whole of KDE in a non-standard location, you will be using the repository KDE 4 which will be installed in /usr. You therefore need to put the Kipi plugins there as well.

Good luck!

can install kipi-plugins

hello,
I would like to install this new release (because error in digikam when trying to export photo to PicasaWeb)
I don't know how to do it. I followed the instructions from http://www.kipi-plugins.org/drupal/node/3 but got stuck at the line: make -f Makefile.cvs (make: Makefile.cvs: Aucun fichier ou dossier de ce type)

or tried to follow the instruction in the README, but again got stuck at the cmake . line. Don't know how to use it. Never compiled anything in my life...
any help?
I am using kubuntu 9.10
thanks
regards

samuel