kipi-plugins 1.3.0 released...

Dear all digiKam fans and users!

digiKam team is proud to announce Kipi-plugins 1.3.0 !

digikam-flickr

kipi-plugins tarball can be downloaded from SourceForge at this url

Kipi-plugins will be also available for Windows. Pre-compiled packages can be downloaded with KDE-Windows installer. See KDE-Windows project for details.

See below the list of new features and bugs-fix coming with this release:

NEW FEATURES:

General : libkexiv2 dependency set to 1.1.0 release.
General : libkdcraw dependency set to 1.1.0 release.

DNGConverter : Update Adobe DNG sdk to 1.3.0.
Support non-square pixels. Support 4-color sensors. Support Fuji-sensors (experimental).

SmugExport : Support export of Captions.

BUGFIXES FROM KDE BUGZILLA:

001 ==> PrintWizard : 232382 : Setting custom page size is impossible.
002 ==> Libkdcraw : 221542 : Build fails due to ambiguities.
003 ==> DNGConverter : 191907 : DNG Converter damages white balance metadata.
004 ==> DNGConverter : 233088 : Compile error on Win32 with MinGW4.
005 ==> DNGConverter : 232991 : DngConverter of kipi-plugins 1.2.0 does not compile under OS X.
006 ==> AcquireImages : 233676 : Desktop-entry-contains-deprecated-key usr/share/applications/kde4/scangui.desktop:105 TerminalOptions.
007 ==> General : 233673 : Spelling-error-in-binary kipiplugin_metadataedit.so kipiplugin_printimages.so kipiplugin_rawconverter.so.
008 ==> PicasaWebExport : 233728 : digiKam picasawebexport unable to display my picasaweb.
009 ==> AdvancedSlideShow : 225153 : digiKam advanced slide show crashes everytimes.
010 ==> JPEGLossLess : 234021 : digikam crash on loading.
011 ==> GPSSync : 234073 : digiKam gpssync no altitude.
012 ==> GPSSync : 233725 : digiKam gpssync unable to geolocalize a picture or movie.
013 ==> PicasaWebExport : 216604 : digiKam crashes on export to picasa.
014 ==> PicasaWebExport : 230201 : Error when trying export to picasa.
015 ==> PicasaWebExport : 216539 : Picasaweb can't select movie to export.
016 ==> JPEGLossLess : 226838 : "Auto Rotate/Flip Using EXIF Information" does not work.
017 ==> PicasaWebExport : 234099 : digiKam picasawebexport labels hierarchy disappears.
018 ==> AdvancedSlideShow : 210959 : Gwenview Advanced Slideshow Crash.
019 ==> PiwigoExport : 235555 : digiKam Plugins Export Piwigo fail.
020 ==> DNGConverter : 233393 : DNG converter doesn't work for Fuji Finepix S6500fd (= S6000fd).
021 ==> GPSSync : 236846 : Geolocation does not work in gnome.
022 ==> DNGConverter : 237914 : Can't compile svn version.
023 ==> JPEGLossLess : 228483 : digiKam 1.1.0 with system libjpeg-8 breaks image rotation.
024 ==> PicasaWebExport : 215688 : Attempted uploading pics to picasaweb.
025 ==> AcquireImages : 238150 : Scangui is untranslated, because it loads no reqired translation catalog.
026 ==> SmugExport : 240420 : Patch to export captions to smugmug.
027 ==> DNGConverter : 240749 : DNGConverter produces black files (Canon 5D mkII).
028 ==> FlickrExport : 221298 : digiKam segfaults on Flickr export.

libkdcraw & libexiv2

Hello,

I'm always amazed of new digikam releases. But this one is a little bit tricky to compile since I can't find neither libkexiv2 >= 1.1.0 nor libkdcraw >= 1.1.0.

Greetings,
Jochen

improvements

These dependencies have been increased due to severals improvements done in these libraries.

Just recompile and install these libs from kdegraphics. See sharedlibs page for details :

http://www.digikam.org/sharedlibs

These libraries are updated exclusively by digiKam team...

Gilles Caulier

Which version of kdegraphics

Which version of kdegraphics are you referring to. The current stable version (4.4.4) doesn't work for me.

code from trunk

kdegraphics/libs from trunk, which will be published officially with KDE 4.5.

Just checkout kdegraphics/libs content. It compile as well with KDE 4.4 or 4.3...

Gilles Caulier

So......

libkdcraw and libkexiv2 from kdegraphics-4.4.4 is not current enough?

not for this release...

not for this release...

Will 4.4.5 have the right

Will 4.4.5 have the right versions?

no : KDE 4.5.0...

no : KDE 4.5.0...

But you can recompile yourself libkexiv2 and libkdcraw as well from kdegraphics. digiKam team maintain these parts

Gilles Caulier

So, we as distro maintainers,

So, we as distro maintainers, will have to stick with digikam 1.2 until KDE releases 4.5 SC? That's very bad as no one will benefit from digiKam >= 1.3.0 except people who're probably using kdegraphics from trunk.

there is no problem really...

You can use as well kdegraphics/libs form trunk with a previous version of KDE as 4.4 or 4.3 release. There is no KDEcore depencies in these library. All will compile fine.

Gilles Caulier

Dear Gilles! I respect your

Dear Gilles!

I respect your work and admire how digikam grew to what it is today, but this dependency on kdegraphics/libs from trunk really hurts digikam as no one will ship it until kde 4.5 will be released...

Greetings
Jochen

there is a problem really...

kdegraphics from trunk does not compile against KDE 4.4.4 stable. error: ‘class KUrlNavigator’ has no member named ‘setLocationUrl’ Error 2

This was a bad move to release Digikam against KDE development code instead of KDE 4.4.4 stable.

You is wrong...

Here i use KDE 4.3.2 and kdegraphics/libs compile without any problem !

The point very important there : you only need kdegraphics/libs content, not the whole kdegraphics !

I'm sure that i said. I develop and maintain (as all others digiKam memebers) libkexiv2, libkdcraw, and libkipi hosted in kdegraphics/libs...

Checkout the right dir and try again. For more info, take a look there :

http://www.digikam.org/sharedlibs

Gilles Caulier

Too bad that these libs

Too bad that these libs aren't released in separate tarballs ;/ Waiting for kde 4.5 final since I dislike having mess in my locally installed packages.

How to compile kipi-plugins and digikam 1.3.0

For Packagers:

Download the libs from kdegraphics trunk.
svn co svn://anonsvn.kde.org/home/kde/trunk/KDE/kdegraphics/libs

Remove the .svn files (not needed)
find ./ -name .svn -exec rm -rf {} \;

Extract your kdegraphics-4.4.4.tar.bz2 file

Replace the libs folder with the libs folder you just downloaded from kdegraphics trunk.

Recompress the kdegraphics-4.4.4.tar.bz2 file.

rebuild kdegraphics package

install the kdegraphics devel package.

Now you can build kipi-plugins and digikam 1.3.0

Tried that. Installed the

Tried that. Installed the libs into /usr/local/ and with the use of cmake-gui specified the exiv2, kipi and kdcraw lib_dirs.

-- Found Kdcraw library in cache: /usr/local/lib64/libkdcraw.so
-- Found Kexiv2 library in cache: /usr/local/lib64/libkexiv2.so
-- Found Kipi library in cache: /usr/local/lib64/libkipi.so
-- Identified libjpeg version: 80
-- checking for module 'libkdcraw>=1.1.0'
-- package 'libkdcraw>=1.1.0' not found
-- checking for module 'libkexiv2>=1.1.0'

Got rid of the version checks and everything compiled fine but then digikam had no thumbs or full-size images and it wasn't obvious if it was using mysql or sqlite. Mysql settings appeared to check out ok but then when I go back into the settings dialog sqlite is selected.

How can this be an

How can this be an instruction for packagers?

I call this "tips for hackers". How do you expect distro packagers to replace a piece of stable KDE with a hacked-up kdegraphics containing development code, for the sole benefit of getting Digikam to compile?

I will pass on this - no digikam-1.3.0 will enter my repository.

Get your act together please.

Eric