digiKam Software Collection 2.2.0 is out...

digiKam-image-title

Dear all digiKam fans and users!

After one month of development, digiKam team is proud to announce the digiKam Software Collection 2.2.0, as bug-fixes release, including a total of 36 fixed bugs. In this release, Photo Title metadata support have been added to customized item names, outside file names.

Close companion Kipi-plugins is released along with digiKam 2.2.0. This release features a new tool coming from Season of KDE 2011 (SoK) project dedicated to create photos layout, and 13 bug-fixes.

digiKam-photo-layout-editor

As usual, digiKam software collection tarball can be downloaded from SourceForge Repository

Happy digiKam...

Any hope for a windows installer

Thank you very much for the new release !!!

Is there any hope to have a windows-installer as well. The application is the best I've seen to manage fotos and I'm not a linux user.

Thanks in advance,
Daniel

Thanks!

Thanks a lot for this release...

the face tagging interface is still crashing after 5-10 new tags in 2.2 :/
i'm trying to rebuild my package to do a proper bug report....

Windows installer

Like Daniel I hope for a windows digikam installer

pleaaaaasssseee.

I third this...

I third this...

i am also waiting as windows

i am also waiting as windows user should also take advantage of this software

I fourth this!

I use both Windows and Linux... Starting to prefer the linux but still need to have the windows systems around. Would be nice to have familar programs between the two.

Roadmap

Thanks a lot for the new version! Digikam is such a great piece of software.

I've just seen the roadmap is out of date. Do you have any new features planned, or is it just a new bugfix release each month? Which is still great.

Any hope for a Gallery3 export?

Is there any hope for a Gallery3 Export plugin as the supplied Gallery2 one doesn't work in 3.

Any hope for a Debian package?

Is there any hope to have a debian package as well?

digikam Debian packages now up in experimental

I have uploaded digikam 2.2.0 to Debian experimental.

Nice

Will it be built for other architectures too?

New interface

Hi,
thanks you for your hard work: I think Digikam is one of the best photo management software for Linux.

I'd like to know if a revamped interface is on the to-do list.

Thanks

export to wikimedia

Hello,

I installed 2.1 a while ago and was looking for the commons.wikimedia export tool but could not find it. Is it implemented in the 2.2 version?

regards, Marie

There is a problem with this tool

This tool is disabled. There is a uncomplete implementation with wikimedia API. 90% is implemented. Still 10% left. Look details here :

https://bugs.kde.org/show_bug.cgi?id=206842#c10

Gilles Caulier

export to wikimedia

thanks for this information - I am very much looking forward to it, hope to see it soon be activated

thanks a lot for digikam in general - it's a great software!

Does not run on OpenSuse 11.4 - undefined symbol

Hi All,

I've just upgraded to DK2.2 and now it doesn't start, need you expert help.

First of all - the upgrade:
- Opensuse 11.4 64bit
- Upgraded from DG 2.1.0
- Upgraded to DK 2.2 from Backports of latest application releases to stable openSUSE releases (openSUSE_11.4). http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/

The Error:

after running exif from konsole I get

"QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
digikam: symbol lookup error: digikam: undefined symbol: _ZN11KExiv2Iface14AltLangStrEdit15setLinesVisibleEj"

and DK just won't start

I've read that people on Kubuntu had this issue with DK 2.1 release so I've checked and I have libkexiv2-10 version 4.7.1-2.3 and libkexiv2-9 version 4.6.0-6.11.1 installed.

Any ideas how to fix it?

I have the exact same issue

I have the exact same issue an I'm very disappointed with the quality of the Digikam releases. I remember at least 4(!) updates of Dikikam where it just didn't start anymore without any meaningful message.
Renaming of the database- and config-files can't always be the right solution...

this is a UPSTREAM problem.

libkexiv2 shared library installed on your system is not updated with digiKam. Typically, your digiKam have been compiled with a libkexiv2 more recent, and this lib have not been updated on your system. It's a broken resolved dependecy from your distro. Contact your linux distro team to solve the problem...

Gilles Caulier

digikam 2.2.0 crashes by using import via USB from known camera

Used OS OpenSuse 11.4 (Tumbleweed)
I updated from 2.1.1
First digikam crashes at every start.
After rebooting OS digikam starts fine.
Trying to import pictures from my camera (Canon SX10IS) digikam crashes.
Same behavior, when I use the automaticaly detected Camera (detected as Canon SX10IS)

Here the crash information:

Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1815e6c7c0 (LWP 13272))]

Thread 6 (Thread 0x7f17f62f7700 (LWP 13273)):
#0 0x00007f180d42738c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1 0x00007f1811054bbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2 0x00000000005be038 in _start ()

Thread 5 (Thread 0x7f17f5af6700 (LWP 13274)):
#0 0xffffffffff600137 in ?? ()
#1 0x00007fff1f1ff7e7 in ?? ()
#2 0x00007f1807c422b3 in clock_gettime () from /lib64/librt.so.1
#3 0x00007f18110a5cf2 in ?? () from /usr/lib64/libQtCore.so.4
#4 0x00007f1811168ffd in ?? () from /usr/lib64/libQtCore.so.4
#5 0x00007f1811169375 in ?? () from /usr/lib64/libQtCore.so.4
#6 0x00007f1811167e3c in ?? () from /usr/lib64/libQtCore.so.4
#7 0x00007f1811167ee5 in ?? () from /usr/lib64/libQtCore.so.4
#8 0x00007f1807991087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#9 0x00007f1807991fa9 in ?? () from /lib64/libglib-2.0.so.0
#10 0x00007f1807992650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#11 0x00007f1811168636 in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#12 0x00007f181113cc22 in QEventLoop::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#13 0x00007f181113ce35 in QEventLoop::exec(QFlags) () from /usr/lib64/libQtCore.so.4
#14 0x00007f1811051be4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#15 0x00007f181111e358 in ?? () from /usr/lib64/libQtCore.so.4
#16 0x00007f18110544d5 in ?? () from /usr/lib64/libQtCore.so.4
#17 0x00007f180d422a3f in start_thread () from /lib64/libpthread.so.0
#18 0x00007f180f6ac66d in clone () from /lib64/libc.so.6
#19 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f17f52f5700 (LWP 13276)):
#0 0x00007f180d42738c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1 0x00007f1811054bbb in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2 0x00007f181373d6a7 in ?? () from /usr/lib64/libdigikamcore.so.2
#3 0x00007f18110544d5 in ?? () from /usr/lib64/libQtCore.so.4
#4 0x00007f180d422a3f in start_thread () from /lib64/libpthread.so.0
#5 0x00007f180f6ac66d in clone () from /lib64/libc.so.6
#6 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f17e1118700 (LWP 13299)):
#0 0xffffffffff600137 in ?? ()
#1 0x00007fff1f1ff7e7 in ?? ()
#2 0x00007f1807c422b3 in clock_gettime () from /lib64/librt.so.1
#3 0x00007f18110a5cf2 in ?? () from /usr/lib64/libQtCore.so.4
#4 0x00007f1811168ffd in ?? () from /usr/lib64/libQtCore.so.4
#5 0x00007f1811169375 in ?? () from /usr/lib64/libQtCore.so.4
#6 0x00007f1811167e3c in ?? () from /usr/lib64/libQtCore.so.4
#7 0x00007f1811167ee5 in ?? () from /usr/lib64/libQtCore.so.4
#8 0x00007f1807991087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#9 0x00007f1807991fa9 in ?? () from /lib64/libglib-2.0.so.0
#10 0x00007f1807992650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#11 0x00007f1811168636 in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#12 0x00007f181113cc22 in QEventLoop::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#13 0x00007f181113ce35 in QEventLoop::exec(QFlags) () from /usr/lib64/libQtCore.so.4
#14 0x00007f1811051be4 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#15 0x00007f181111e358 in ?? () from /usr/lib64/libQtCore.so.4
#16 0x00007f18110544d5 in ?? () from /usr/lib64/libQtCore.so.4
#17 0x00007f180d422a3f in start_thread () from /lib64/libpthread.so.0
#18 0x00007f180f6ac66d in clone () from /lib64/libc.so.6
#19 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f17dc6a3700 (LWP 13315)):
[KCrash Handler]
#6 0x00007f180f65139d in realloc () from /lib64/libc.so.6
#7 0x00007f18029bc187 in register_platform () from /usr/lib64/libdc1394.so.22
#8 0x00007f17da746ec6 in gp_port_library_list () from /usr/lib64/libgphoto2_port/0.8.0/usb.so
#9 0x00007f1812e13568 in ?? () from /usr/lib64/libgphoto2_port.so.0
#10 0x00007f180a6eda41 in ?? () from /usr/lib64/libltdl.so.7
#11 0x00007f180a6ed697 in ?? () from /usr/lib64/libltdl.so.7
#12 0x00007f180a6ee681 in lt_dlforeachfile () from /usr/lib64/libltdl.so.7
#13 0x00007f1812e1397d in gp_port_info_list_load () from /usr/lib64/libgphoto2_port.so.0
#14 0x000000000074456f in ?? ()
#15 0x00000000004e5292 in _start ()

Thread 1 (Thread 0x7f1815e6c7c0 (LWP 13272)):
#0 0x00007f180f6b99b2 in __libc_disable_asynccancel () from /lib64/libc.so.6
#1 0x00007f180f6a3507 in poll () from /lib64/libc.so.6
#2 0x00007f180572dc2a in ?? () from /usr/lib64/libxcb.so.1
#3 0x00007f180572e1a3 in ?? () from /usr/lib64/libxcb.so.1
#4 0x00007f180572e234 in xcb_writev () from /usr/lib64/libxcb.so.1
#5 0x00007f180d9b3cc6 in _XSend () from /usr/lib64/libX11.so.6
#6 0x00007f180d9b4207 in _XReply () from /usr/lib64/libX11.so.6
#7 0x00007f180d9afb13 in XSync () from /usr/lib64/libX11.so.6
#8 0x00007f17e8c046b1 in ?? () from /usr/lib64/gstreamer-0.10/libgstximagesink.so
#9 0x00007f17e8c047f6 in ?? () from /usr/lib64/gstreamer-0.10/libgstximagesink.so
#10 0x00007f17e8c04b09 in ?? () from /usr/lib64/gstreamer-0.10/libgstximagesink.so
#11 0x00007f180723c114 in g_object_unref () from /lib64/libgobject-2.0.so.0
#12 0x00007f17f31a9a2e in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_gstreamer.so
#13 0x00007f17f31cd159 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_gstreamer.so
#14 0x00007f17f31c9ed3 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_gstreamer.so
#15 0x00007f17f31c9f29 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_gstreamer.so
#16 0x00007f18155ec7b4 in Phonon::MediaNodePrivate::deleteBackendObject() () from /usr/lib64/libphonon.so.4
#17 0x00007f18155de7c8 in ?? () from /usr/lib64/libphonon.so.4
#18 0x00007f18155dea79 in ?? () from /usr/lib64/libphonon.so.4
#19 0x00007f180f60e5a1 in __run_exit_handlers () from /lib64/libc.so.6
#20 0x00007f180f60e5f5 in exit () from /lib64/libc.so.6
#21 0x00007f18102f6128 in ?? () from /usr/lib64/libQtGui.so.4
#22 0x00007f1811b847d8 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib64/libkdeui.so.5
#23 0x00007f180d9b678e in _XIOError () from /usr/lib64/libX11.so.6
#24 0x00007f180d9b403d in _XEventsQueued () from /usr/lib64/libX11.so.6
#25 0x00007f180d9a48df in XEventsQueued () from /usr/lib64/libX11.so.6
#26 0x00007f181032f0a7 in ?? () from /usr/lib64/libQtGui.so.4
#27 0x00007f1807991087 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#28 0x00007f1807991fa9 in ?? () from /lib64/libglib-2.0.so.0
#29 0x00007f1807992650 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#30 0x00007f1811168636 in QEventDispatcherGlib::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#31 0x00007f181032f1ae in ?? () from /usr/lib64/libQtGui.so.4
#32 0x00007f181113cc22 in QEventLoop::processEvents(QFlags) () from /usr/lib64/libQtCore.so.4
#33 0x00007f181113ce35 in QEventLoop::exec(QFlags) () from /usr/lib64/libQtCore.so.4
#34 0x00007f181073f89e in QDialog::exec() () from /usr/lib64/libQtGui.so.4
#35 0x00000000004e6389 in _start ()

UPSTREAM problem

https://bugs.kde.org/show_bug.cgi?id=268267

Online update is on its way

There is an online update to libdc1394 coming to openSUSE 11.4 that includes the upstream patch.

I have the same camera and

I have the same camera and the same issue, I'm trying everything, but there is no way, with the last update of DK it wont crash, but it doesn't start the download and the peview of the camera.
I'm with DigiKam from the beginning of it, I like and I hope this issue will be fixed soon...

Giorgio

kipi-plugins 2.2.0 ?

where is the tar ball of kipi-plugins 2.2.0 ?

at SF there is only the 1.9 version

in digiKam SC tarball

look in "extra" subfolder...

Won't work on natty, won't on

Won't work on natty, won't on Oneiric :(

What i dont understand, why

What i dont understand, why Digikam 2.1.1 work on oneric with KDE 4.7.2
and Digikam 2.2.0 wont work on same platform ...

git repos

Hi DigiKam team!
I'm just wondering if digikam-2.2.0 is now available in the git repository at:
http://anongit.kde.org/digikam-software-compilation

This is really the easiest way to get an update for Ubuntu .. but I can't see anywhere if it's been updated with the latest version.

//Will

Look git commit ID of digiKam and kipi-plugins

Checkout code from git/master using digiKam Software Collection and switch digiKam and kipi-plugins sub -repositories to right revision for 2.2.0 release. Look in git history for that :

https://projects.kde.org/projects/extragear/graphics/digikam/repository/revisions/master/changes/project/NEWS.2.2.0

https://projects.kde.org/projects/extragear/graphics/kipi-plugins/repository/revisions/master/entry/project/NEWS.2.2.0

Support MS Windows

Dear people,

I? a enthousiast user of Digikam on Linux, Ubuntu 11.04. Version 2.2 runs flawlessy here. But I would recommend further development of a windows port of Digikam, multiplying users of the program and attracking more developers and donators. Whoever does the job: KDE for windows or The Digikam team or a yet unknown party, it's equal to me. I've got version 2.0RC running reasonable on an XP Pro-machine.

Greetz
Wim

Do NOT bother for a windows version!

Please do NOT bother for a windows version!
Linux is the perfect desktop environment anyway and I can not conceive digikam in the closed restricted space of windows.
An OS with only a virtual desktop!
Personally I discovered the world of Linux because of digikam and I am glad I did!

Keep up the awesome work!

1. Not all people have the

1. Not all people have the option to run Linux as their main OS. And a dual boot system just for DigiKam is a little oversized.

2. Luck at the posts above yours. Getting newer program versions in Linux is a real pain. A newbie like me is completely lost.

2.2.0 windows installer is under finalization

A new contributor named Ananta Palani has started to update digiKam 2.2.0 installer for Windows. It must be released next week end on SourceForge.net repository.

digikam-win7

Will DigiKAM for Win support AVCHD metadata in sidecars?

Hi,

I hope this version of DigiKAM will run stable on Windows.

Can any kind person with enough expertise in these things tell, if DigiKAM will support writing metadata also for AVCHD videos (*.mts, *.m2ts) in xmp sidecar files? If I remember right metadata can be attached to RAW image formats in sidecars by DigiKAM. But can this xmp-sidecar -functionality be applied also for all other file types people are using - for example mts and mp3 files?

(I hope also that DigiKam can display thumbnails for mts files in Win 7, because Windows Explorer can do that.)

All this would make DigiKam a real digital asset manager - not only photo manager - for win.

-pb

YUPI Digikam 2.2.0 UBUNTU ONERIC

Jupiiii :) last digikam 2.2.0 work in ubuntu Oneric 11.10 with last KDE 4.7.2

I found this PPA for Ubuntu

https://launchpad.net/~hrvojes/+archive/kde-goodies

It worked for me on Ubuntu 11.10 and Gnome 3.2

I'm an artist with 72,000 photos and manage them with DigiKam. I'm so happy about how well this software and community work.

Thank you for all your efforts, they are most appreciated!

All my best,
Pete Ippel

"I make art and share."

http://peteippel.com
http://hypermodern.net