digiKam Software Collection 2.8.0 is out...

splash2.8.0

Dear all digiKam fans and users!

After one month since 2.70 release, digiKam team is proud to announce the digiKam Software Collection 2.8.0, as bug-fixes release.

See the list of files closed with this release into KDE bugzilla.

digiKam software collection tarball can be downloaded from SourceForge Repository

Happy digiKaming...

version number

Thanks for another update :)

I wonder about version numbering though : if there are only bugfixes in the release, why isn't it 2.7.1 ? When I see a x.y.z version scheme, I expect x=major feature/rewrite, y=misc feature z=bugfix. Digikam doesn't seem to follow that definition lately. Or if it seems like too much trouble deciding which number to bump, what about YYYY.MM ? No indication of what's in the release, but at least no flawed user expectation either.

I think the last digit should

I think the last digit should just be dropped and be done with it. Minor releases can be done when ever seen necessary (from minor bug fixes to small feature releases) and major releases when big changes are done or when the minor number gets too big.

Congrats

Looks like a lot of bugs were squashed here. Congratulations!

I love digiKan

I love digiKam (I'm running v. 2.5 on my Vista-Computer without any serious troubles)! But when will you release a Windows-version 2.80?

digiKam 2.8.0 and 2.9.0 for Windows released today

Unfortunately, release schedules for Windows are a little irregular because KDE SC for Windows (the software that digiKam relies on) is rather unstable, including the build environment. This means that to get the latest bug fixes the build environment has to be constantly updated. There are very few developers working on KDE SC for Windows, so many compilation problems are encountered with each release. Since we are doing this in our spare time it can take quite a bit of time with each release, and releases will be sporadic. Unfortunately, that is just the way it will have to be for the foreseeable future. Regardless, you can download digiKam 2.9.0 from here.

Cool

Can't wait to have it running in my Arch system!
Thanks for all your work :)

crash

digikam crashed on my debian sid 64 bit - form 2.7 verzion when I try geotag, date repair and more :( - probably something with libkipi :-/

For me the same on a OpenSUSE

For me the same on a OpenSUSE 12.1 x86_64

no libkgeomap...

...but it's not reproducible here. Sound like a packaging problem...

On big problem with digikam

On big problem with digikam is, that I always have to use the unstable repositories for digikam. It would be really nice, if digikam would run without any special considerations on a recent Linux-Distribution.

The main problem seems to be the libkgeomap 2.8.0+git20120828-1.1-x86_64 from the openSUSE_12.1 unstable repository. With this libkgeomap also digikam 2.5 crashes.

So currently I have to revert to the stable repositories, where I only can get digikam 2.5.

how to lose a good reputation

Hello,

first, I like KDE, k3b, and other K based stuff. In past I spent some time for digikam to send some bug reports to pkg debian team. And I further use this application with kipi-plugins but I'm searching for an alternative.

Reasons are not some temporary bugs, for some weeks there were problems with white-balance, some problems with cameras have to do with gphoto. Sometimes there were some discussions with pkg-debian team, they didn't accept, that some versions of digikam were build against developement stuff of kde graphic libraries, which wasn't released as stable. I'm not a developer and cannot judge about it.

But since version 2.6.0 there is a problem with all functions, which need cimg library and digikam crashes. As a reaction of this bug I've found this comment of a core developer of digikam:
"It crash in CImg library, which is not maintained anymore. I cannot
update or fix it.

I try to find a student to work on this code to port from CImg to Gmic
library which is the replacement... "

It seems, Gilles, that you've not found a student yet, with version 2.7.0 digikam crashes, now with 2.8.0 digikam crashes. I've changed the system, to verify, if this bug has to do with the status of Sid / siduction, but on OpenSUSE 12.1 with digikam 2.7.0 it is the same behaviour. Yesterday I've installed a fresh Kubuntu 12.04, added the digikam ppa of Philipp Johnson, and digikam 2.8.0 crashes.

"Bearbeiten Sie Ihre Fotos wie ein Profi", this you can read when starting digikam. Sorry, but such a behavoiur of an application, which is dicussed as a reference application under Linux and such a reaction of a core developer has not to do with professional work.

And if all cimg stuff isn't important for you, we user have to accept this but then it would be better to deactivate this features. Offering broken features with now three versions of digikam and talking about a professional work with digikam is not acceptable for a reference application.

Sorry for my bad english, and sorry for this rant, but I'm annoyed, not because of a bug, but because of handling it.

i agree with that :)

i agree with that :)

A Suggestion

I haven't verified the accuracy of the above comment myself but if any of the developers of digiKam happen to be reading this, I would suggest simply copying CImg into the digiKam project as a static lib for now and fixing the bug there. (heck, even include an old version of CImg if it worked before) Then put porting to Gmic on the roadmap for the future. That way it will keep users happy and the project should remain stable until the port is done.

digikam

Hello,

first comment about reputation was from me, I've forgotten to put my name in the name-field.

Your suggestion could be an option, but about the best procedere I cannot judge because I'm a user, not a developer.

But you can be sure, the described error is not a fake and the qutoe about finding a student is from Gilles, not from me.

And I hope, I've pointed out, that I don't want to start a stupid flame like KDE versus Gnome or anything similar.

Kind regards,
Holger

investiguations are under progress for next 2.9.0

Look here :

https://bugs.kde.org/show_bug.cgi?id=303119#c7

Crash is relevant o CImg library bug, not digiKam as well... digiKam is not the rest of the opensource world...

Before to critic digiKam project, take a care !

Gilles Caulier

Hello Gilles, "digiKam is not

Hello Gilles,

"digiKam is not the rest of the opensource world..."

In this point you're right, indeed, we've a lot of stuff in free software world and I've clarified, that digikam is part of a software pool, you can call reference applications for Linux. :-)

"Crash is relevant o CImg library bug, not digiKam as well..."

That digikam need other stuff, a lot of libraries, is known by me, I'm not a developer but a linux user for a long time. :-)

"Before to critic digiKam project, take a care !"

Gilles, I did not critzise, that there are some bugs in stuff, digikam depends on, I've mentioned gphoto as an example for some errors, which have not to do with your work. My rant is against your reaction after getting a bug report about it. And digikam 2.7.0 and also 2.8.0 furthermore offers functions, which are building against broken cimg stuff. Knowing about it but offering it and commenting it with "I've to find a student" german spoken "Mal schauen, wann ich jemanden dafür finde" that is the purpose of my rant, not the bug situation itself.

But it seems, that in 2.8.0+git20120821-1.2 this bug has gone, thanks a lot.

Apart from that and it is not a joke: I spent some time here for my criticism because I like digikam and kipi-plugins. And I hope, you understand it in a right way.

Kind regards,
Holger

Is there any news about Bug 303850?

As discussed with the previous version, digiKam won't start on MS Windows with an USB drive plugged in. This is rather annoying and makes digiKam unusable for me.
Is there any intention to fix this? Maybe a roadmap?
Thanks

Where did you find a windows

Where did you find a windows version 2.8.0. after all?

It really becomes annoying to always having to come back here, look for a new windows version and not finding anything. I see it's not made for windows users, though.

Where to find the Windows Version

Look at:
http://sourceforge.net/projects/digikam/files/digikam/

You find the link here under "Download"\"Package", at the bottom of the screen.

Sorry, no 2.8 until now

Sorry, just saw 2.8.0 and did not check, no Windows Installer for 2.8.0 yet.

But doesn't matter for me as long as this bug is in.

digiKam 2.8.0 and 2.9.0 for Windows released today

You can download digiKam 2.9.0 from here. As mentioned above, bug 303850 has been fixed with the update from KDE SC 4.8.3 to KDE SC 4.8.5.

Bug fixed in digiKam 2.8.0 and 2.9.0 for Windows released today

Sorry for the inconvenience, its annoying for us as well. Unfortunately time is very limited as there are very few Windows developers for KDE SC (the software that digiKam depends upon). It turns out the bug was due to KDE SC for Windows, not digiKam. This has been fixed by moving from KDE SC 4.8.3 that I used for digiKam 2.6.0 and 2.7.0 to KDE SC 4.8.5 for digiKam 2.8.0 and 2.9.0. You can download digiKam 2.9.0 from here. Please file a new bug report if you encounter any further troubles.