digiKam Software Collection 3.0.0 and 3.1.0 for Windows Released

digiKam3.3.0-windows

At long last I am pleased to announce the simultaneous release of digiKam 3.0.0 and 3.1.0 for Windows built against KDE 4.10.2. If you have a short attention span and want to download it immediately see the attached link.

There were numerous bugs I had to fix in digiKam and KDE before release, and fixing them took more time than expected. Extremely sorry for the delay! Rest assured, it was worth it thanks to a major enhancement on the Windows side of things: a new 'solid' interface thanks to the KDE windows team which will drastically speed up time before album display when switching between albums and when viewing digiKam after some minutes away.

Bugs fixed for Windows include:

1. Inability to use UUIDs for volumeids on Windows

2. Loss of collection during upgrade for certain collection paths

3. JPEG rotation from album viewer failed to work correctly and often crashed (for some types of collections you will need to press F5 to refresh the thumbnails, I will try to fix this for 3.2.0 or 3.3.0)

4. Temporary thumbnails are were not cleaned up correctly

5. File paths were not displayed in native Windows format (i.e. a backslash - if you see any paths that are not in the correct format please file a bug report or reply to this)

6. KDE did not handles mixed case files on Windows in most cases correctly (i.e. you could not save mixed case files properly and filename comparison did not always work properly - there may be some lingering places where it does not)

7. Misc. compile time fixes and code clean-up

Known problems

1. After rotating an image using the rotate icons in the thumbnail view, the user may have to press F5 to see the change

2. Bugs listed on KDE Bugzilla

Regardless, without further ado I give you Digikam 3.0.0:

http://download.kde.org/stable/digikam/digiKam-installer-3.0.0-win32.exe

and digiKam 3.1.0:

http://download.kde.org/stable/digikam/digiKam-installer-3.1.0-win32.exe

Please let me know if you encounter any problems or file a bug report.

Enjoy!

P.S. I hope to release 3.2.0 in the next week or two.

Thank you!

Hello Ananta!

I haven't tried it out yet, but thank you very much for all your effort! I'm excited to try the Windows version soon (especially of the coming version with its facial recognition feature)!

/Carl

You're welcome!

I hope it works well for you. I'm looking forward to the face recognition feature as well :)

THANKS

Thank you sp much I have waited for this so I can get started with sorting my Photo collection!!!! I´ll definetly donate if this time it doe not crash before getting to sort photos :-).

You're welcome

And if it does crash, let us know so we can fix it this time!

Digikam 3.1.0 win. Thumbnails

Digikam 3.1.0 win. Thumbnails disappear after changing to other album view. Refresh (F5) does not help. Restart helps sometimes to show thumbnails at first, but error will pop up again.

What error?

Do you see an actual error message pop up or do you mean that the problem shows back up again? If you wait a few minutes will the images finally show back up? And just to confirum, you downloaded and installed using the link at the top of this post? I ask because the effect you are seeing was one of the things I fixed. It could be that you have a device attached that is causing problems for solid to list. Would you mind filing a bug report and specify the problem you encountered and what drive devices you have attached to your system (ex. x-number of hard drives, cd-rom drive, dvd-drive, camera, flash, etc).

Thanks!

No error message - just a problem

I'm seeing this error on KUbuntu 13.04 running digiKam 3.1.0. I have an album with 265 photos. It shows 265 photos. Then if I select them all, I only have 186.

Sounds like a different issue

I'm pretty sure this is a different issue. You're talking about selecting all images in a folder showing only a fraction of the expected images selected, whereas original poster is talking about all images disappearing when switching albums.

Have you tries selecting ranges of photos or shift-clicking multiple ranges to see if you can select more than 186?

Either way, please file a bug report.

In-painting crashes Digikam 3.0.0 and 3.1.0

Digikam 3.0.0 and 3.1.0 on Windows 7/64-bit crashes whenever I try to use In-painting. Tested on two computers.

Thank you for all your work!

Jacal

Noticed the same problem with

Noticed the same problem with 32 bit Win Vista Prof. Another computer run with 64 bit Win 7.

After all, fantastic program and grate work!

P.S. How about of importing pictures direct from camera?

-OTSO-

Fixed in next Windows release (and 3.3.0 codebase)

Took me a bit to find the cause of this, but was a thread leak + a config issue. Fixed with this commit:

http://commits.kde.org/digikam/421b387878e84d272f63dc12d67bef37d5eeb0cf

It's in the 3.3.0 codebase, but I will include it in 3.2.0 release that I'm going to do shortly. This bug affected digiKam on all platforms.

Thanks for your patience!

Please file bug report

Would you please file a bug report and list the steps to reproduce the error? Also, just to confirm, you tried the installer listed in this post?

Thanks!

geolocation edit bookmarks.....NOTHING happens

Hi!
Great program, i will forget picasa, geosetter, lightroom...
BUT:
picture / geolocation / bookmarks / edit bookmarks....

nothing happens. There is no error, no program crash.
I can switch between "google maps" and "marble virtual globe", the maps are ok,
i can add bookmarks, geo-locations, new bookmark folder....
only the right-mouse selection "edit bookmarks" doesn't work. no reaction.
One month ago i installed digikam for the firts time (Version 2.9),
it was the same error on two different win 7 computers.
thanks
Jürgen

Please file a bug report

Sorry you encountered the error! Would you please file a bug report? I'll try to fix for the next version.

Thanks!

geolocation edit bookmarks.....NOTHING happens

Hi!
It's Bug 321274

Thank you!
Jürgen

Fixed in next Windows release

As I state in bug 321274 keditbookmarks is in kde-baseapps and I wasn't building kde-baseapps. Will be included in next release. Sorry about that!