Download

Before you can use digiKam, you must first download and install it. There are many ways to achieve that:

  • Use a compiled official bundle provided by the team.
    This is the most easy way to test the recent stable version everywhere. This include universal Linux AppImage bundle, MacOS Package, and Windows Installer.
  • Use a compiled package provided by your operating system.
    Take a care, digiKam version can be outdated.
  • Use a compiled pre-version bundle provided by the team for testing purpose only.
    This is the most easy way to try the current implementation not yet released officially. This include universal Linux AppImage bundle, MacOS Package, and Windows Installer.
  • Compile the last source code archive from official repository.
  • Compile the latest version from git repository where we currently work in.
    This is even more complicated, but as recent as it gets. This is needed when you want to help us to find bugs or help us develop. This way is for peoples who want to contribute or if pre-version bundles are not enough to investigates problems at run-time.

You can choose the one which fits you best. We provide detailed instructions for each of them.

Note: check the dependencies before trying to compile digiKam.