digiKam

Professional Photo Management with the Power of Open Source

digiKam 5.4.0 is released…

digiKam-5.4.0-Front

Dear digiKam fans and users,

Following the 4th release 5.3.0 for the 5.x series published in November 2016, the digiKam team is proud to announce the new release 5.4.0 of digiKam Software Collection. This version introduces several improvements to the similarity search engine and a complete re-write of video file support.

Our new contributor Mario Frank has significantly improved the usability of the fuzzy sidebar functionality by offering more information to the user. In duplicates search, every result now contains the average similarity of the potential duplicates to the original. This information can be used to sort the results. The individual elements of the duplicate search result can be sorted by similarity to the original image now, which also works in fuzzy search and sketch search.

digiKam-5.4.0-Fuzzy

Everywhere in the fuzzy sidebar, the table view can now show the precise similarity value to the original image/sketch as column. This option is located in the item properties sub-menu of the column context menu.

Mario has also added the possibility to drag an image that is not imported in digiKam but present on the system (local file) and drop it into the Fuzzy search. This way, similar images can be detected without the need to import them.

digiKam-5.4.0-ExternalSimilarity

In duplicates and fuzzy search, a similarity interval can be specified instead of the minimum similarity. This makes it possible to exclude images with a similarity above the maximum threshold. Using this functionality, the user can exclude a series of nearly identical images, series shots for example. This interval can also be given in the maintenance menu.

Wolfgang Scheffner who works on the comprehensive digiKam handbook has updated most of the menu descriptions. The chapter about the Camera Interface has been replaced by a chapter about the Import Interface. Descriptions of the right sidebar were added and updated. In addition to that, we've done a lot of polishing and minor corrections and improvements.

digiKam-5.4.0-Handbook

Simon Frei, yet another new contributor, has improved the feature to group images. Grouped items are now processed together. Previously operations would only apply to the top image in the group (i.e. the image displayed when grouped images are hidden). In other words, applying, for example, a tag to a top image in a group will assign the tag to all images in this group.

digiKam-5.4.0-GroupItems

Simon has also improved the Batch Queue Manager by adding the ability to process only the current queue. Previously, the "Run" command processed all queues. Now it only processes the current queue. To process all queues, use "Run all".

digiKam-5.4.0-BQMQueue

Maik Qualmann worked on tags to improve the way to manage tag hierarchies, history and completion. He has also fixed several bugs in Flickr and Google export tools. As usual he spent a lot of time on improving code elsewhere in digiKam core for better stability.

digiKam-5.4.0-tagsEdit

digiKam is now fully ported to the QtAV framework to handle video and audio files. Previously, digiKam 4.x used the Phonon component. Starting with version 5.0.0, digiKam relied on the Qt5Multimedia framework. Both required installing additional codecs by end users for operating systems other than Linux, and using GStreamer in the background for Unix-like systems. The use of extra codecs on MacOS and Windows introduced many differences in media decoding results that depended of codecs supported natively by each platform. The end user was required to solve this problem after installing digiKam. In other words, digiKam wasn't ready to handle video and audio files right out of the box.

The GStreamer used on Linux posed another problem. From the technical point of view, it's not easy to deploy and troubleshoot, and there are multiple bugs filed in Bugzilla regarding the missing support of media files in digiKam. Worse yet, even when GStreamer is installed, often Qt5Multimedia refused to work properly. Finally, when the universal AppImage bundling for Linux was introduced few month ago, we often struggled to integrate GStreamer codecs and to have a working version of digiKam with support for media files. This has never been completed due to strange, complex, unsolvable run-time dependencies everywhere. In other words, GStreamer did not work as expected.

Besides the fact that Phonon and Qt5Multimedia rely on extra codecs, the way to extract video thumbnails with this framework is incomplete and unpredictable. This main feature used throughout digiKam to show a fast view of video did not work natively as expected, and thus was not suitable for end users.

The QtAV framework provides the solution to this problem. The framework relies on a comprehensive codecs library and tools from FFmpeg. Codecs are the same across all platforms and the framework API is very similar to the one of Qt5Multimedia. The integration was very fast, and we were able to add new features like video rotation in preview and video slideshow.

Another good point about QtAV framework is to be able to play animated image as a video. This want mean that aGIF, aPNG, or MNG files can be preview as a video instead a static image with only the first frame.

digiKam-5.4.0-videoSlideShow

The QtAV integration in bundles has been done easily, especially with AppImage. digiKam is now linked to QtAv/libAV instead of using extra run-time dependencies as with Qt5Multimedia. The bundle has been limited to GPL2 codecs from FFmpeg which covers the most frequent video file formats taken with cameras, like MP4, MOV, and AVI containers. GPL2 codecs permits redistribution of bundles everywhere without breaking patent restrictions included in non-GPL codecs from FFmpeg.

In digiKam bundles, we have also introduced the new code from Exiv2 0.26 that has not yet been officially released. As the Exiv2 project takes a while to release this version, we made the decision to use the current implementation. It's mostly finished, and it introduces improvements to video metadata support as well as fixes for a long list of bugs that have been discovered since the Exiv2 0.25 release. Using Exiv2 0.26 should fix crashes caused by this library that have been reported upstream with previous digiKam versions.

digiKam-5.4.0-Exiv2-0.26

This new digiKam version also includes latest libraw 0.18, whose release coincided with the digiKam release schedule. This version of the raw decoder includes a long list of new supported cameras and fixes several internal bugs reported by digiKam team upstream.

digiKam-5.4.0-LibRaw0.18

For furher information, take a look at the list of more than 200 issues closed in Bugzilla.

digiKam software collection source code tarball, Linux 32/64 bits AppImage bundles, MacOS package, and Windows 32/64 bits installers can be downloaded from this repository

Happy new year 2017

Thx again for the great work!

and for the work on the next version!

Thank you for your work on

Thank you for your work on video support ! I use digikam to manage video files (mainly documentaries/concert/music video) and every improvement in this area is much appreciated ! I hope to see video controls (play/pause) in the future :)

PS: the link to "QtAV framework" is broken

Thanks...

...all external links fixed...

Video play/pause/position is already implemented. In Video Slideshow, this only show when mouse is on top of screen.

Great ! Not sure if video

Great ! Not sure if video control was recently added but my digikam version is outdated anyway.
Cheers digiKam team and happy new year :)

Thank You for your great

Thank You for your great Work.

The new GIF view is really useful, but is there an Option to repeat them automaticly?

not yet

There is no option to repeat aGIF sequence

writing problem

Hello,
It seems that I can't write pictures with Appimage. I can't modify and save images with image editing, it seems that Digikam can't write pictures (no permissions ?). It's my first use of AppImage, what can I do ?
Thanks for the beautiful job, I really love Digikam.
Regards

not reproducible here..

Did you run AppImage file from your home directory ?
Did you run AppImage with your standard account ?
Did you try to save images into your home directory ?

Hi! I have a library going,

Hi!

I have a library going, but now I can't import new photos using ANY of the methods, including drag and drop. . .

Please help. . .

One limitation

... from AppImage is to run digiKam before to plug the camera...

yes, I created a folder

yes, I created a folder Home/appimage/ and execute from here
yes, I'm admin
yes, in my pictures folder.

I have a warning message and a red cross

Thanks!

Now video thumbnails are working on OSX. Very good work! ;-)

Dépendances

bonjour
désolée je parle très mal anglais
j'avais la version 5.3 et tout allait bien (depuis la version 4, tout va très bien)
Puis hier j'ai voulu lancer le programme.... qui a DISPARU !!!
mon raccourcis sur le bureau me dit que le programme n'existe pas.
J'ai fait une recherche sur mon ordi et, en effet, plus de Digikam.
C'est quoi cette histoire???
Alors j'ai voulu installer la dernière version, et, dans la console ça me dit que l'installation n'est pas possible car des dépendances sont insatisfaites !!
Comment dois-je faire?
Merci

mise à jour système...

C'est probablement dû à une mise à jour système qui a retiré automatiquement l'application suite à des dépendances obsolètes.

La solution la plus simple est de télécharger la version autonome au format AppImage. Ca marche sous tous les Linux. Cela n'installe rien sur le système et ne nécessite pas de droits super-utilisateur.

C'est dans la zone de téléchargement du site. Cela est proposé depuis la version 5. La dernière est 5.4.0. Il y a une version 32 bits et une version 64 bits.

Une fois le fichier téléchargé, on rend celui ci exécutable et on le lance. C'est tout. Il y a des explication générique ici :

https://forum.ubuntu-fr.org/viewtopic.php?id=1987878

salut je revenais ici pour

salut
je revenais ici pour copier la liste des dépendances non satisfaites et ne m'attendais pas à avoir une réponse, et en french en plus ;-)
Je suis tombée sur cette page : https://forum.ubuntu-fr.org/viewtopic.php?id=1999513
j'ai tenté les explications... mais sans résultats.. enfin, toujours le même :-(
Je ne connais pas ce format "AppImage", à part ce que tu me précises, quelles sont les différences (avantages/inconvénients) de ce type de programme?

AppImage est un conteneur

... universel pour Linux. Toutes les dépendances sont à l’intérieur. Ca marche partout, et la dernière version est toujours disponible. Pas la peine d'attendre le paquetage officiel de ta distribution Linux. Il y a même la pré-version non encore officielle pour tester les dernières fonctionnalités et les corrections de bogues.

D'autre part, toutes les dépendances sont optimisées aux petits oignons.

https://en.wikipedia.org/wiki/AppImage

En fait c'est un méga paquet

En fait c'est un méga paquet qui inclus non seulement le programme mais aussi les dépendances?
Comment ça marche?

Et pour les MAJ?

Bon, c'est super, ça marche, je t'aime
Et je me pose une question, pour les MAJ?
j'ai toujours les lignes ppa:philip5/extra vont-elles encore fonctionner?

oui

Le paquet officiel n'est pas impacté. C'est complètement autonome du système d'exploitation.

Pour le mise à jour, on télécharge le nouveau AppImage et on le lance. C'est tout...

merci beaucoup :-)

merci beaucoup :-)

Estelle, if you use my PPA

Estelle, if you use my PPA with Digikam packages with ubuntu 16.04 or a linux distribution based on it then check if your version of KDE have been updated from KDE 5.5.5 to something newer like like KDE 5.8.5. IF you now use an updated version of KDE then you ALSO need to add my "kubuntu-backports" PPA that contains updated packages of digikam rebuilt to work with newer versions of KDE than what came with official ubuntu 16.04.

droits d'écriture

Je profite de l'occasion pour m'exprimer en français ;)

je suis le message du 13 janvier...

retour d'expérience sur AppImage. Je n'ai rien modifié mais j'ai bien les droits d'écriture à présent. Les mystères de l'informatique... Cette version marche parfaitement. Merci !

Par contre, suite à la mise à jour des paquets sous kde, l'aperçu des images ne fonctionne toujours pas dans la 5.4 des dépôts. J'apprécie d'avoir des appli qui se mettent à jour toutes seules, c'est pour cela que je conserve cette version.

Encore bravo pour le travail réalisé

Media support ?

Hi, thanks for the update.
How to enable media support ? On Fedora, Digikam has been updated to 5.4, but now there is no media support at all.
In Help > Component Information, "Media Player Support" is "No".

- Should user install additional libraries (I have installed libqtav and qtav-players : no impact on digikam) OR
- is it a compiler option (in this case the Fedora package is not video ready) ?

ask to packager...

It's a compile time option. Ask to packager to rebuild digiKam with this option.

Thanks for quick answer, as

Thanks for quick answer, as usual ;)
FYI, done: https://bugzilla.redhat.com/show_bug.cgi?id=1415498

bad news with Fedora :(

Oops, bad news, Digikam will not be entirely available in Fedora repository anymore. At least media support will not be enabled because Qtav is not free :( (see Fedora packager answer in bug report)

Not completely free ???

What is that ? QtAv is free using GPL license :

/******************************************************************************
QtAV: Multimedia framework based on Qt and FFmpeg
Copyright (C) 2012-2016 Wang Bin

This file is part of QtAV

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
******************************************************************************/

in all cases...

Use the AppImage linux bundle and forget Fedora package... digiKam include Media support through QtAV for you...

How get media support when not compliant to Linux distro policy?

Well, it seems that the fact qtav is free is not enough regarding Fedora policies. I suppose the same problem will happen with other distro's (Debian, ... ?)
So unfortunately, full version of Digikam cannot be delivered anymore through official repositories of several Linux distro's.

I'm not a developer, but would it be possible to implement the media feature as an addon that could be installed aside ? I'm hoping for a solution because I'm now with a limited version of Digikam (video feature is quite important for a lot of users I think).

And concerning the AppImage linux bundle: unless I have not understood its concept, it is for me a big step backwards: you are like 15 years ago when you have to install all your soft independently, update them manually, ... I can imagine its useful for testing purposes, but I prefer using the advantages of Linux repositories.

Final decision

Hello guys,

I'd like to ask whether this is really a final decision. I had been using Digikam for many years, I love that software, how it allows me to organize all my pictures, the map, the labels and the simple-to-use enhancing pictures. Anyway I'm not allowed to use ffmpeg, therefor qtav, therefor I won't be able to show videos, which is really unfortunate for family album.

I don't know how much intrusive the change is but wouldn't there be a possibility of keeping the old way (yes, it crashes sometimes, but I'm kind of used to that) as well as this cool new, but not-available-everywhere way?

I thought there was some temporary bug, today I had more time to search and found this issue... It made me really sad because I don't know of any other suitable software for organizing pictures on Linux.

Why...

... you are not allowed to use ffmpeg ?

Company laptop, software

Company laptop, software patents... It's safe in personal usage, but on a company laptop even when not used for business can be tricky and is disallowed by our employer.

ffmpeg is modular...

and default modules are GPL2 so no patents. By modules this want mean the codecs.
another one is GPL3 and last one is patented.
The DK bundle only include GPL2 codec, and this is the default install under Linux. It's enough to run digiKam and video taken from a DSC.

The same logic can be seen with GStreamer codecs and VLC codecs.

So before to crying about patents take a look and try to understand how it work...

Thank you for the

Thank you for the clarification, I'm not an expert, I only know we don't have allowed to install other repos on our machines (CentOS/Fedora) and the resolution from Fedora is they will never include it. On my personal laptop I downloaded your provided package which somehow works but I was told I can't do this in the company laptop.

With this said I have no idea how hard is it to have both way (the old and new, eg. as compile option) I'd definitely like that. If not than I'll probably have to look for another alternative (as I don't have the knowledge to contribute to this amazing project, which would be ideal, I know...).

You don't need to compile for Linux...

Use AppImage universal Linux Bundle. It will work on all Linux computer as well. There is nothing to install...

Note : AppImage is compiled under CentoOS 6.8

Video without sound

Hello,
OK, I finally tried the appimage package under Fedora.
The video plays fine, but there is no sound (whatever the video) ! Is it an appimage problem, should I install additional dependencies ?

See this report...

https://bugs.kde.org/show_bug.cgi?id=375651

Time adjust?

Hi, has Time Adjust gone missing? That was an extremely useful feature because people (including me) don't always have their camera times set correctly. Now all I can find is the batch manager, and I didn't see how I could preview the time adjustment (making it tricky to fast-forward 7 years or so).

Time adjust? -> Batch Queue Manager, Base Tools, Time Adjust

Check out the Time Adjust tool in the folder Base Tools of the Control Panel in the Batch Queue Manager.
Did work for me. At least in Digikam 5.3.0

Tired of trying to get this to work

Ive been trying to get digikam to work for a year now. Ive used Linux Mint 17 and 18, Kubuntu, Tumbleweed, and the new appimage files in Mint 18. Nothing is stable. All I want to do is use Digikam, preferably >5.0, with mysql (mariadb) without it crashing. WHAT DO I NEED?

Tired of trying to get this to work -> .appimage

Go to the download section of this page, and choose the official bundle provided. There choose and download the matching .appimage. Make the downloaded file executable ($ chmod 755 digikam-5.4.0-01-x86-64.appimage) and run it from the command line ($ ./digikam-5.4.0-01-x86-64.appimage)

digikam-5.4.0-01-x86-64.appimage works for me on Ubuntu 16.04 like a charm.

IMHO the easiest way to test a new version and does the trick for me for day to day work as well!

Windows version

How well does Digikam work on windows now? Win 10 in particular.

I used to use it on linux some years ago but I am windows only these days.

Video Metadata Problems

Hello!

Thank you for your hard work, this software is great. I have a couple issues with my video files, however. DigiKam doesn't read the metadata without me selecting "Read from and write to sidecar files" in the configuration window, and then clicking "Write metadata to image" for each video file. Is this necessary?

More importantly, however, I can't seem to write my geolocation information to my video metadata. When I add GPS coordinates to my video file through the geolocation editor, the information does not appear in the metadata.

Also, only one tag shows up in the IPTC window under keywords, even when I apply more than one tag to the video file.

Could anyone help me with this?

Hi there! Digikam crashes on

Hi there! Digikam crashes on export or save operations. It happens both on 32 & 64-bit versions of software. OS is Windows 7 64-bit. Thanks for any kind of help!

Trying a little more I see

Trying a little more I see that all works fine after customizing of raw behavior and save parameters in settings.