digiKam Software Collection 4.0.0 released...


Dear all digiKam fans and users!

digiKam team is proud to announce the release of digiKam Software Collection 4.0.0. This version, include many new features introduced by completed GSoC 2013 projects:

  • A new tool dedicated to organize whole tag hierarchies. This new feature is relevant of GoSC-2013 project from Veaceslav Munteanu. Veaceslav has also implemented multiple selection and multiple drag-n-drop capabilities on Tags Manager and Tags View from sidebars, and the support for writing face rectangles metadata in Windows Live Photo format.
  • A new maintenance tool dedicated to parse image quality and auto-tags items automatically using Pick Labels. This tool is relevant to another GoSC-2013 project from Gowtham Ashok.
  • Showfoto thumbbar is now ported to Qt model/view in order to switch later full digiKam code to Qt5. This project is relevant to another GoSC-2013 project from Mohamed Anwer.

  • A lots of work have been done into Import tool to fix several dysfunctions reported since a very long time. For example, The status to indicate which item have been already downloaded from the device is back. Thanks to Teemu Rytilahti and Islam Wazery to contribute. All fixes are not yet completed and the game continue until the next beta release.

  • This release is now fully ported to Qt4 model-view and drop last Q3-Support classes. The last pending part was Image Editor Canvas ported and completed by Yiou Wang through this GoSC-2013 project. In the future, port to Qt5 will be easy and quickly done, when KDE 5 API will stabilized and released.

  • This release include also the multi-core CPU support for severals tools which require a lots of computing, as Sharpen, LocalContrast, Noise Reduction, and all visual effects tools.

As usual with a major release, we have a long list of files closed with this release into KDE bugzilla.

digiKam software collection tarball can be downloaded from KDE repository

Have fun to play with your photo using this new main release

digiKam Team...


Well done and thank you to everyone involved!

Windows Support

I take advantage of this release to ask if the support of the windows platform has been enhanced? and if this version is available on Windows?

I use the linux version but my parents the Windows one.

But I was unable to use it very well because they are french and I don't have found a way to change the language of digikam :(
I think it is in the "kde settings" but the french is not available :(

When will the windows port of

When will the windows port of 4.0 be made available?

french setting

The easiest way to put it in French is to use a environment variable : LANG=fr.UTF-8

You can add it in config panel --> system & security --> system --> advanced system parameters and click on "environment variable", add a new variable (system or user wide), call it "LANG" and set it to "fr.UTF-8"
(in french : Panneau de configuration --> Système et sécurité --> Système --> Paramètres système avancés, "Variables d'environement", ajouter une nouvelle variable soit pour tout le système soit pour l'utilisateur courant, la nommer "LANG" et lui donner la valeur : "fr.UTF-8" ).

OR, If you prefer you can also make a bat file to launch your digikam :
"C:\Program Files (x86)\digiKam\bin\digikam.exe"

Very excited!

I've been waiting for this release to switch my main workflow.
Really looking forward to it, thanks for all the work! I will contribute some money when I can.

Thanks to the team for all

Thanks to the team for all the hard work! Been looking forward to this release!
Amazing software with a lot of new features to try out

Merci encore !

installing 4.0.0 in Opensuse 13.01

Thanks for the effort and the new version.

Trying to install in Opensuse 13.01 got an error: libkdcraw.so.23 not available.


I also use opensuse, I'll try

I also use opensuse, I'll try to download by the correct repository, as soon as possible.
do yuo know if the new version maintain the old database without problem?


I have installed on previous 3.5.0 withou problem. In fact works a lot better.


Opensuse install

Solved. Using KDE Extra repository.


hi antoni How can I add an

hi antoni
How can I add an extra dedicated repository in opensuse for new digikam?
can yuo write me the exact typing...

Hi guys, I use opensuse

Hi guys,
I use opensuse 13.1
I can not upload the new version
I tried to add extra kde on yast but I do not see digikam4.0
anyone has any solution

Opensuse repository

see KDE:Extra / openSUSE_13.1

Ubuntu Softwarepaket


In Ubuntu (Ubunt 14:01 LTS) Software Center digikam only the version 3.5 appeared available.
Where can I find the version of digikam 4.0?

You can try my PPA:

You can try my PPA: https://launchpad.net/~msylwester/+archive/digikam

works fine for me!

works fine for me!

Kubuntu 12.04 LTS

Any chance of a version for 12.04 ?

Sorry, but no time to manage

Sorry, but no time to manage several versions, for now I'm happy to have the trusty ppa working...

Installation of new Digikam 4.0

Hello, I'm new to Linux (about 6 months of use) and I would like to install the newest version of Digikam 4.0 but before I get started I would like to thank the developers for their tremendous effort they put in to make this project happen. Thanks so much. Ok that being said I am hoping to get a little instruction and compiling and installing the tarball. So far I've downloaded digikam4.0.0.tar.bz2. I"ve also installed the dependencies, I've gotten away with avoiding Linux applications that require compiling until now. Thanks for your help.


If you happen to use Ubuntu

If you happen to use Ubuntu (and on 14.04), you can look into using the commenter (Michal Sylwester) above's PPA

With the following commands:
sudo add-apt-repository ppa:msylwester/digikam
sudo apt-get update
sudo apt-get install digikam

Installation of new Digikam 4.0

That worked perfectly. Thank you.

BTW It took me a few trys to leave this post on account the captcha was a little to differcult for me to make out. :)

* difficult

*difficult - spell check in Linux Firefox isn't so great either. :)

digikam 3.1 doesn't update on ubuntu 13.04

I tried with ppa:msylwester/digikam PPA,
but when launch the
sudo apt-get install digicam
Terminal answers my digikam is already at last version, but the one I have installed is version 3.1

Easy install

Thanks for the ppa instructions. This is valuable information and should have been included in the article alongside the Tarball link for us non-techies.
Also, the easier way in the 'buntu distros is to add the ppa in Software Sources. E.G. go to the Software Manager, then go "Edit" - "Software Sources", "Other Software" - "Add" then enter ppa:msylwester/digikam. The update will start and Digikam 4.0 will be installed, without needing any text commands. Which are beyond most non IT peoples experience. Such as us photographers.

Otherwise have a look at the

Otherwise have a look at the README.LOCAL file in the tarball. (It will say you need to run .bootstrap.local and some other commands). Remember the dependencies need to be the development files (so you can compile - often the dev files filenames end in '-dev')


it's nice software

local contrast tool

I've been using digikam for many years. The new version seems faster and more responsive. My only complaint is the new algorithm for the local contrast tool. Somehow, I was unable to get the enhancing results of the previous versions. Even at modest levels, the results look dull and unpleasant. Otherwise, many thanks for the nice work.

what's new?

Hi guys,
I'm fully satisfied with digikam, and I say this around to your friends and colleagues, even if I can not perform some simple workflow in batches (do not keep in memory the steps of the workflow ... resizing jpeg-watermark with text)

I installed the new version 4.0, (open suse) but I do not see important changes compared to the 3.5.
what's new in your opinion.
I have two libraries around 100,000 photos, what benefits do you think?

look this file


thank you that's ok umby

thank you
that's ok

shooting yourself with not distributing binary downloads

A new release is not a new release if there are no binary downloads for the major distros, so if you are not ready to put up official binary deb or rpm files or, much better, setup repositories for the major distros (debian, ubuntu, redhat) then new release is not ready. Do not publish a "new release ready" blogpost, if in fact you are not ready.

Preparation of binary packages or distribution repositories is not some "bothersome afterwork", but it is the most important part of your development cycle - if you are not willing to make the software delivery process easier, then why are you doing it at all?

Please rethink your non-existent distribution policy and at put up some official deb files of this new release, thanks.

Windows binaries would also be great

I totally agree and I would love to see the binaries for Windows too.

It's such a pity that there are no binaries for this awesome great software. I'm 100% sure that there would be a lot of people willing to work with this software if there would be an easy installer/compatible binaries.

You could reach a lot bigger audience in providing the binaries and probable could also get some more money for this great piece of software.

I'm still hoping for the windows release...

Thanks for the great development.

Windows installer (current code - next 4.1.0)

Hi all,

As current Windows packager is very busy this summer, I finally take few hours to fix code, compile, and run windows packaging script.

I build a 32bits version of my Windows 7 KDE installation including digiKam and KDE. It compiled with MSVC 2010 + few extra libraries, as OpenCV. Not all dependencies are here and this want mean that some extra features can be dropped.

Translations files are missing too. I never found a good way to have translations files compiled here. digiKam will be in English.

So, this installer come without guaranties to run fine on your system. On mine, it's start and is usable...

At least this installer is better than nothing. It must be used for testing purpose only...

I agree. I m Using Digikam

I agree. I m Using Digikam for more than 5 years, supported it, and always the same trouble with "new versions": i have to trust someone i dont know (using the ppa) to get the new version. This is hardly acceptable for me. Please dont ignore this issue!

Anyway, this time i dit it.
- faster
- no video playing inside digikam -> it crashes (before it did)

All together i m already looking for a alternative, but in the linux-world i found nothing. Ideas?

p.s. i still apreciate the good and hard work and still like digikam, but...but...but...s.o.

Phonon component.

Problem already reported to bugzilla and relevant to KDE Phonon component.


Did you try LightZone ?


they require registration,

they require registration, not an option

Registration is only for

Registration is only for logging into download page, not to use the program.

anyway it's up to you