digiKam Software Collection 4.2.0 released...

digiKam-LabelsView

Dear digiKam fans and users,

The digiKam Team is proud to announce the release of digiKam Software Collection 4.2.0. This release includes important features to simplify photograph workflow :

These features have been introduced by Mohamed Anwer Google Summer of Code project which have been completed in time and judged ready for production.

As usual, we have worked hard to close your reported issues since the previous stable release 4.1.0. A list of the issues closed in digiKam 4.2.0 is available through the KDE Bugtracking System.

The digiKam software collection tarball can be downloaded from the KDE repository.

The updated (2014-08-08) Windows installer can now be downloaded from the KDE repository as well.
You only need the updated version if you previously got an error saying that cudart32_55.dll was missing when you tried to run digiKam. This update fixes that problem.

digiKam 4.2.0-win32-FaceManagement

Have fun playing with your photos using this new release,

digiKam Team...

compile error

Hello,

make fails with this error message:

In file included from /home/***/digikam-4.2.0/extra/kipi-plugins/gpssync/track_correlator_thread.h:36:0,
from /home/***/digikam-4.2.0/extra/kipi-plugins/gpssync/moc_track_correlator_thread.cpp:10,
from /home/***/digikam-4.2.0/extra/kipi-plugins/gpssync/kipiplugin_gpssync_automoc.cpp:4:
/home/***/digikam-4.2.0/extra/kipi-plugins/gpssync/track_correlator.h:32:31: Schwerwiegender Fehler: libkgeomap/tracks.h: Datei oder Verzeichnis nicht gefunden

best regards

Andy

libkgeomap

you must use libkgeomap from digiKam tarball to compile. You use previous version from your system.
To force compilation with local one, use this cmake argument : -DDIGIKAMSC_USE_PRIVATE_KDEGRAPHICS=ON

libkgeomap

Hello,

thanks for yoru quick response. I tried it, but the result is the same as above...

best regards

Andy

cleanup cmake cache.

Before to reconfigure cmake with new option, clean up cmake cache, or delete cmake buil dir...

Hello, I've deleted the whole

Hello,

I've deleted the whole source dir and begun from scratch.

best regards

Andy

Not sure if it's still

Not sure if it's still relevant to you, but if anyone else get the error, you can just remove your current version of libkgeomap with apt-get.

Then it will compile and install correctly. ;)

Fix for building on OS X

I had the same error when building on OS X (macports).
I found that FindKGeoMap.cmake looks for libkgeomap/version.h.cmake, but in that folder I found libkgeomap/version.h.cmake.in instead. So I changed FindKGeoMap.cmake (in 3 places) to look for FindKGeoMap.cmake.in instead, and I got past the error.
My solution may be terribly wrong, but it seems to have worked. I have not tried the geomapping functionality of digiKam yet.
PS: I found this when building latest from git, but I see the situation is the same in the 4.2.0 tarball.

make a patch please

Please, can you provide a patch to check all changes made. thanks

Face Reconition, faces not yet confirmed filter

Is there a way to show all and only these faces that have been detected & recognized by digikam but not yet confirmed by the user?

with a large collection of pictures, it gets hard to confirm new faces!

Here is a filled wish!

Thanks

https://bugs.kde.org/show_bug.cgi?id=336253

Thanks!

Thanks for release!
I just installed 4.1.0 yesterday, and I was getting frequent crashes while browsing photos and changing albums.
I was going to file a bug report, but then update was announced and crash -problem disappered! Great timing! ;)
(using Ubuntu 14.04 and digiKam packages from Philips ppa)

Attempt to upgrade to digikam4.2.0 failed

I have been working with digikam 4.0.0 and having issues with sudden crashes. Today I saw the announcement of digikam v 4.2.0.
Tried to upgrade using the recommended way for kubuntu:
~$ sudo add-apt-repository ppa:kubuntu-ppa/backports
~$ sudo apt-get update
~$ sudo apt-get install digikam
this last command triggered the following message in the terminal:
Reading package lists... Done
Building dependency tree
Reading state information... Done
digikam is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
~$
to ensure I had the right version I followed with the command
~$ digikam -v
that triggered the following message
Qt: 4.8.6
KDE Development Platform: 4.13.2
digiKam: 4.0.0

What gives, is it that Kubuntu backports are not up to date?
are there other ways to do it?

Thanks

Can not start digiKam

Hello,

digiKam 4.2 installed on Windows 7 x64. DigiKam can not start. Error message missing cudart32_55.dll.

Best regards

Snooker

I reported the bug on the kde tracking system

I experience the same problem as Snooker also on Win7 x64. Uninstalling and reinstalling digikam 4.2 resulted in the same error message. I reported the bug on the kde bug tracking system.

Compilation Mistake

I Accidentally left CUDA support enabled when I built the OpenCV libraries. You probably do not have a NVidia graphics card or a recent enough version of the CUDA libraries. Either way, that was my mistake and it should not have been included. I will rebuild and make a new release in a day or so. The bug you referred to is #338085. Very sorry for the troubles!

It did solve the issue.

It did solve the issue. Thanks for reissuing the windows installer :)

I tried to install digikam

I tried to install digikam (windows) a few minutes ago but the cudart 32_55.dll file is still missing.

The windows test installer,

The windows test installer, linked on the bug report, worked fine. Apparently is the KDE repository that need to be updated.

Correct

Yes, you are correct. I am waiting on the new installer to be mirrored across KDE official hosts so I can link the installer from there, so for now use the link from the bug report. Sorry for the trouble! Updated installer on KDE servers is now linked in main text.

no smoothing in Preview

No idea if it is due to the Digikam upgrade to 4.2 or something else, but I'm now getting a very grainy image in the preview panel as if it was using some bilinear filtering. At 1:1 it is alright but there is no smoothing for viewing at less than 100%. In Slideshow it works fine again. Anyone else experiencing the same problem?

see bug #337231

With 4.2.0 release we have introduced a new code to handle HQ screen
resolution as retina display from Apple. Entry in bugzilla is this
one :

https://bugs.kde.org/show_bug.cgi?id=337231

We check this code under Linux, OSX and Windows with different screen
sizes, and all work fine.

Perhaps screensize returned by your system is wrong.

We recommend to post a comment in this bugzilla file to have feedback
from original contributor and start investigations...

The description doesn't seem

The description doesn't seem to fit. I'm not using OSX but Linux and a standard 24" 1920x1200 display. The pixel size looks right in all modules, at 1:1 it is perfect. It's only the preview image when downscaling uses most likely a bilinear filter instead of some smoothing. Is there a hidden setting somewhere for that?

no settings...

there is no settings for that...

I am experiencing the same

I am experiencing the same problem on my system. When "Preview Load Full Image Size" is set to true, I am getting on some photos strange patterns in the preview, which vanish only when I am increasing the preview to 50 or more percent. My photos have a size of 36 Mpx. Obviously the algorithm that reduces the image to the screen size, creates some kind of a moiree structure if the underlying picture has a regular pattern e.g. a brick wall. This did not happen with DK 4.1.0. Also I can confirm the grainy picture in the preview. These effects disappear if I set "Preview Full Image Size" to false. BUT in that case I am loosing almost totally the high resolution of the photos when taking a 100% view. I am downgrading to DK 4.1.0 .
My Screen is a BenQ flat panel with a resolution of 1920 x 1080. Operating system: openSUSE 13.1

Ditto

I am experiencing the same bug on Gentoo, 1920x1080 screen. When no scaling is performed, the image preview is as it should be. When scaling is performed, it's horrible.
Robin: bilinear filtering would result in a smooth image. This looks more like no filtering.

See: https://bugs.kde.org/show_bug.cgi?id=338138

Ah, thank you for filing

Ah, thank you for filing it.

I thought bilinear being the fastest and worst quality filter it would be it, but you're right there's probably no filtering at all

Digikam 4.2 is going very well under Windows

I was a bit upset due to slow Digikam performance in my Linux box (a weak HP Microserver 40L), which was built to provide Samba shares and web serving.
My desktop is a old Intel Q6600 + 4GB + GTX650 + Windows 8 + 1Gbps network. Digikam database is MySQL installed in my Microserver.
The performance is very good, totally usable and I can also play a bit in my notebook over wi-fi as well
Great job. I almost bought Ligthroom some months and regret nothing for moving to Digikam.
Congratulations

Finally, a stable windows build

I can absolutely agree, digiKam 4.2 works like a charm under windows, since the OpenCV issues have been resolved. Just remember to get the digiKam-installer-4.2.0-win32-2.exe (the article still links to the first build).
For me it's the first time that I can use digiKam under Windows without crashes and having access to all the features is just awesome! Keep up the great work :)

Thanks!

Thank you both for the kind feedback, very glad to hear it is working so well for you!

I have been waiting on the KDE servers to mirror the new installer so I can link it on the official server and will link the official one as soon as its ready (it's identical to the one on Google docs that you linked).

Updated installer on KDE servers is now linked in main article text.

No previews, no thumbnails...?

I just installed on Windows 7/64, the newest version without that "cudart" error message.

Installation works fine, everything looks okay.

BUT... I see no thumbnails or previews, all photos are shown as generic icons, even JPGs.

In preview mode I see an error message below the image beside the little icons: "Failed to load image". Well, it does not load one of many that I have, no matter what file format.

What can I do?

Please file a bug report

Please file a bug report and attach a screenshot. Please give information like where your photos are physically located (like external hard drive, network, etc), whether you are using a roaming profile (like at a university), what type of database you are using and any other information you think might be relevant. Also, can you click/double-click on the thumbnail to see the full-size image?

Latest KDE update in Kubuntu backports breaks digikam install

Hello,

since yesterday I've been experiencing the following problem (and it seems I'm not the only one according to #kubuntu on IRC):

The latest backports update in Kubuntu removes digikam (and a whole lot of other apps it seems) due to unmet dependencies. I know this is probably a packaging issue with Kubuntu, but maybe you have an idea...

When I do apt-get install digikam I get:

The following packages have unmet dependencies:
digikam : Depends: libkgeomap1 (>= 1.0~digikam4.0.0) but it is not going to be installed

I tried resolving the issue manually, but this just results in more dependency issues due to newer versions of other libraries.

Any help would be greatly appreciated.

Keep up the good work!
Chris

I don't know how you update

I don't know how you update or what other packages and/or PPAs you are using that could make that conflict but try to install/update libkgeomap1 and look what kind of conflicts it gives as it doesn't want to be installed. As for now this is too little information for knowing the root of the problem.

So sudo apt-get install

So sudo apt-get install libkgeomap1 gives:

The following packages have unmet dependencies:
libkgeomap1 : Depends: libmarblewidget18 (>= 4:4.9.90) but it is not going to be installed

Then sudo apt-get install libmarblewidget18 yields:

The following packages have unmet dependencies:
libmarblewidget18 : Depends: libastro1 (= 4:4.13.3-0ubuntu0.1~ubuntu14.04.1~ppa5) but 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed
Recommends: marble-plugins (= 4:4.13.3-0ubuntu0.1~ubuntu14.04.1~ppa5) but 4:4.13.97-0ubuntu1~ubuntu14.04~ppa2 is to be installed

I guess then the problem

I guess then the problem comes from that you are using the new plasma 5 (beta?) from an outside source and the digikam packages you are installing are build to use plasma that comes with kubuntu (backport)? Therefor you get a version conflict with kde and plasma packages and different software depending on different version. I know that my packages are not build against plasma 5 anyway but you are using the kubuntu standard packages of digikam and I guess they don't build against it or either in backports.

KDE 4.14.0 available in kubuntu backports

New KDE 4.14.0 is now available in kubuntu backports, replacing libmarblewidget18 with libmarblewidget19. As libkgeomap1 depends on libmarblewidget18 (and digikam depends on libkgeomap1 which can not be installed), would it be possible to check if libkgeomap1 works OK with libmarblewidget19 and enhance the dependency to allow users with KDE 4.14 to continue using digikam?

BTW: I really do admire your job, allowing Linux users to effectively manage large collections of photos in such advanced tool. I am seriously suffering as I can not sort photos of my kids from vacation and share them with family abroad (tags+edit+mass upload) in any other tools than digikam ;-)

Does libkgeomap1 works with libmarblewidget19 ?

Could you please verify if libkgeomap1 works with libmarblewidget19 and enhance the dependency list not to stick on libmarblewidget18, which is not available on KDE 4.14 ?
In case of I am wrong in what I wrote, could you verify how this was worked out for libmarblewidget15 or libmarblewidget16, as I do not remember having issue like this.
I am really missing digikam, especially when holidays are gone.

It's not just a matter of

It's not just a matter of expanding a dependency list to make it work. All digikam and it's packages need to be rebuilt against KDE 4.14 that are in the kubuntu teams Backports PPA to make it work with that version of KDE and that breaks my Digikam packages for anyone using the KDE 4.13 version that comes with standard (k)ubunt 14.04 instead. For it to work for all users there need to be two different setups och digikam builds and packages (PPAs), one build for people using standard KDE 4.13 that comes with (k)ubuntu 14.04 and one build for people using the Kubuntu teams backports PPA with KDE 4.14.

Hi Philip5, thank you for

Hi Philip5, thank you for your answer and the explanation which is understandable also for non-developers.
I have tried to solve the issue on my side by purging backports repository, but there was 500+ packages issues identified if I would continue, so I gave up.
As digikam is using marble libraries for some time already, how was this resolved in the past? I found https://bbs.archlinux.org/viewtopic.php?id=134602, but it doesn't describe the solution. Do digiKam developers know more?
I understand that creating new repo for who-know-how-much users could be too much extra work, but would it be possible for you to prepare build for KDE 4.14 users and send it to backports repository admins? It should not break anything as backports repository users are already using KDE 4.14.

It's not that big of a

It's not that big of a problem really for me to setup packages for kde 4.14. I have done so before and have a PPA that just need to be added for those using kde 4.14. It's just that I haven't uploaded anything there for some time. I just need to setup a virtual machine with kubuntu 14.04 and kde 4.14 to test it first before upload.

If there is demand for it I might be able to do it tomorrow.

Oh, that would be great!

That is a great news for all users with KDE 4.14! I think it would even deserve brief article in news section, to inform all users who stops waiting for this to be resolved (I can imagine a lot of people are now returning from holiday, running updates...).
Hope you will have no trouble in the way!

Now digikam 4.2 is up there

Now digikam 4.2 is up there on my kubuntu-backports PPA for(k)ubuntu users with KDE 4.14.x. You need both my "extra" and the "kubuntu-backports" PPA to make it work and it's ment to be used with KDE 4.14.x packages provided by the Kubuntu teams "backports" PPA. If you don't use the kubuntu teams backports PPA then you shouldn't use this kubuntu-backports PPA of mine but only my "extra" PPA.

https://launchpad.net/~philip5

Great job, it works smoothly

Great job, it works smoothly now!
I do encourage anyone with KDE 4.14.x to add Philip's kubuntu-backports repo to have digikam again.
Philip, many thanks to you, especially when considering end of holidays with a lot of new photos, it really helped users like me a lot!
Tomas

force install of libkgeomap1 to allow digikam install

I remove libmarblewidget18 and forced the install of libkgeomap1 (downloaded from the http://packages.ubuntu.com pages) and then digikam installed without a problem.AFAICT kgeomap allows both googlemaps and marble to be used, presumably the marble part is going to fail - but then for me there are already so many crashes in recent digikams [the sqlite problems on the whole I think] that I probably won't notice ...

dpkg force install

Sorry should have said, I used dpkg to force the install or the already downloaded (from website) package:

-$ sudo dpkg --install --force-depends ./libkgeomap1*

couldn't work out how to do that with just apt-get.

I removed libastro1 and then

I removed libastro1 and then I was able to install the libmarble, libkgeomap and digikam. Another problem crept up though: when I start up digikam, it finishes the initialization, shows the main screen with "no active process". However, at about this time it starts using all available CPU (400%) and grabbing memory very quickly. When it gets to about 83% of the system memory (and brings the system to practical halt), the system kills it - and I can never know what it is trying to do there with all those resources.

confirm,

happened to me as well

Crashes all the time

I really like digikam, but unfortunately for me it's been unusable since version 3.5 (approximately). It crashes non-stop: I can't use it for more than 5 minutes before it crashes. I even went as far as installing a fresh copy of kubuntu 14.04, with a new home directory to see if this would solve the problems. Unfortunately, the crashes persist.

It seems that specifically looking at videos, and also browsing the tags makes things worse.

How do I report a bug, or find out what is causing the crashes? Is there a log file that I can look through?

libsqlite UPSTREAM bug...

Look this entry in bugzilla. It's an upstream problem relevant of SQlite library...

https://bugs.kde.org/show_bug.cgi?id=329697

Digikam Win, Malicious file ?

Chrome is blocking the download from kde

"digiKam-installer-4.2.0-win32-2.exe es un archivo malicioso y Chrome lo ha bloqueado."

It says it's a malicious file and insists when I try to unblock it

Does anyone have the same issue ? is there any problem with the file ?

Just tried...

...and no problem here to download with Chrome.

Do you have any 3rd party anti-virus working in background ?

Chrome being presumptuous

There is no problem with the file, it is Chrome being annoying. When a program is self-extracting installer like this one and is not hosted on a secure server, Chrome will often assume it is malicious. You can read more about it here and here.

We could solve this problem by getting a signing certificate, but that is expensive and we don't have the money for it at the moment. As a test, you could see if Chrome still gives you the warning if you download the exact same file from my Google docs. You could also try downloading from a different mirror server as Google may have a problem with that specific host/country, so perhaps a mirror in a European country would eliminate the warning.

You can check that the file hash matches those listed on the KDE mirrorlist.

Digikam window missing "digikam toolbar" ?

Hello,

I have installed digikam 4.2.0 on Win7 (installer ...win32-2) and after several crashes (systematic problems with caption/tags) I just saw that the "digikam toolbar" (Browse/Album/Tag/.../Export/Settings/Help) that I can see on some example pictures is missing.
Do you know how can I find it ?
I don't think I played with settings, it is a freshly re-installed digikam version...

Thanks,

Pascal

Sorry, I just found the

Sorry,

I just found the "Ctrl+M" command...

But I still have these crashes linked to caption/Tag...

Regards,

Pascal

Please file a bug report

Glad you sorted it out! Sometimes the menu fails to re-appear after entering/exiting fullscreen mode. In future you could also try quitting digiKam, moving your digikamrc file from 'C:\Users\<your user name>\AppData\Roaming\.kde\share\config' and restarting digiKam so it is recreated and seeing if that solves the problem.

As to the crashing, please file a bug report and give information like where your photos are physically located (like external hard drive, network, etc), whether you are using a roaming profile (like at a university), what type of database you are using, and any other information you think might be relevant, like minimum steps you take to reproduce the crash and an image that causes the crash.

No more tags-linked crash...

I don't know if it is linked to menu toolbar or because I just made a "fuzzy update" but everything seems ok :)) !
Thanks,
Pascal

Windows vers 4.2.0 Digikam won't resize images

Hi
I was so pleased to discover Digikam running under windows. I first downloaded vers 3.4.0 and it installed fine but the Tools/Resize Images failed on everything I tried (single images and batch). I then discovered that there was a vers 4.2.0 which I now have running and the resize still does not work.
I normally run Digikam on my home Suse 13.1 Linux platform and love the editor.
I have tried both proportional and non-proportional settings and it fails every image.
This is a result using Proportional (1 din) with 640 size set.

convert -resize 640x640 -filter Bessel -quality 75 -verbose C:/Users/GarthDesktop/Desktop/MyPictures/Geelong 8Aug2014 night/Half Size/DSC_0259.png[0] C:/Users/GarthDesktop/Desktop/MyPictures/Geelong 8Aug2014 night/Half Size//DSC_0259_1.png

Invalid Parameter - 640x640

It seems to me that it hasn't figued out the sizing of the other dimension (eg 480 or whatever).
I have looked through the Configuration setup for the Edit functions and can't see anything I need to set. In Linux there is nothing to do - the resize just works :-)
Is there anything I can do to sort this out?

I have now tried the Batch

I have now tried the Batch Queue manager and that does work - just a long winded way of resizing.
I should have mentioned in my 1st post that I'm running this on a Windows 7 64bit system.

Resize tool uses ImageMagick

For some reason the batch tool seems to use internal methods to resize, while the Tools->Resize menu is trying to use ImageMagick's convert program. On Windows, even with ImageMagick installed, digiKam sees the convert program from Windows, which is meant to convert a FAT hard drive to NTFS. Could you file a bug report?

Bug report submitted - thanks

Bug report submitted - thanks for the help.
Hope this is resoved soon. Batch editing is not often provided in photo editors and of all the programs I have used Digikam is by far the best. Thanks guys for the work you've done on this.

Thanks

Hello!
I just want to thank the team for this outstanding work. Digikam is the only Linux photography management program that fits all my needs.
I'm currently use the stable 3.5.0 version.

Cheers.
Christian

Still (since 4.0.0) when you

Still (since 4.0.0) when you want to add a face tag, you're presented a combo list of what matches what you're typing, but you cannot click it because mouse click is ignored. You have to select the right tag with arrow keys and press Enter.

Both in album view and in face detection/recognition view.