digiKam Software Collection 4.14.0 released...

digikam4.14.0-2

Dear digiKam fans and users,

The digiKam Team is proud to announce the release of digiKam Software Collection 4.14.0. This version is the result of another bugs triage on KDE bugzilla where more than 20 files have been closed. Thanks to Maik Qualmann who maintain KDE4 version.

This release will be the last stable release dedicated from 4.x series. We are now focused on next 5.0.0 release planed on spring 2016. This next main version will support Qt5 and KF5. The first beta1 will be released soon.

In this release, OpenCV 3.x is now supported for face management and others tools based on OpenCV algorithm. SOme work have been done about overlay icon to improve usability. Icons are now re-sized accordingly with thumbnail sizes, and a new icon have been add to quickly run slideshow in full-screen mode.

For more details, you can consult the huge list of the issues closed in digiKam 4.14.0 available through the KDE Bugs-tracking System.

The digiKam software collection can be downloaded from the KDE mirrors.

Have fun to use this new important digiKam stable release.

digiKam Team...

PKG Version?

Hye,
This time you're not providing a .pkg mac file?
I wasn't able to make the last pkg runs on macosx el capitan but I was wondering if this one should work.

Genrally, is the 5 version focused on making digikam work on debian and macosx?!

Thanks for your reply

macports broken...

Currently it's impossible to build KDE4 under Macports because both Qt4 and Qt5 are installed while the process, which is not compatible...

Thanks for your reply, I gues

Thanks for your reply, I gues the latest comment is the same as mine, windows users feels a bit left backyard.

I was able to get it build

I was able to get it build using this patch to bootstrap.macports:


37,38c37,38
< export QTDIR=${INSTALL_PREFIX}/lib
< export QT_INCLUDE_DIR=${INSTALL_PREFIX}/include
---
> export QTDIR=/opt/local/libexec/qt4
> export QT_INCLUDE_DIR=/opt/local/libexec/qt4/include
76d75
< -Wno-dev \
83,85c82,84
< -DQT_QT_INCLUDE_DIR=${INSTALL_PREFIX}/include \
< -DQT_LIBRARY_DIR=${INSTALL_PREFIX}/lib \
< -DQT_QMAKE_EXECUTABLE=${INSTALL_PREFIX}/bin/qmake \
---
> -DQT_QT_INCLUDE_DIR=${QT_INCLUDE_DIR} \
> -DQT_LIBRARY_DIR=${QTDIR}/lib \
> -DQT_QMAKE_EXECUTABLE=${QTDIR}/bin/qmake \

Fine about 4.14.0. but what

Fine about 4.14.0. but what about windows version?

Windows users seems to be

Windows users seems to be forgotten, no 4.13, no 4.14. Will we have to wait for version 5?
Thanks in advance to the windows builder.

It is pity. I has intrested

It is pity. I has intrested about this software, but now is goes, like we finns says: it goes down like the tail of the cow.

Don't complain. Are you

Don't complain. Are you missing any features or are you bitten by any bugs?
I'm on Kubuntu 15.10 myself which was just released and digiKam comes in version 4.12

I'm working on packages of

I'm working on packages of Digikam 4.14 for Ubuntu 15.10 (wily) right now and also bringing back the geo-location and map features and some other dependent packages updates and fixes for Wily users. Will upload it to my PPA as soon as possible, maybe in the next few days. Have been busy with life and haven't had time for this last two weeks.

Thank you

You guys are the best. There's nothing that I've used before that is as good as Digikam. Thank you.

Just a question: Will the format of the metadata stored/written be same and compatible across Digikam4 and Digkam5 ?

yes

nothing has changed...

bundled plugins

Hello,

Up till 4.13.0, the plugins were bundled as part of digikam in extra/ folder.
IN 4.14.0, that is no more the case. Is it intentional ? Is digikam, henceforth, not going to ship those libraries in its archive ?

Nothing about this change seems to be mentioned in the release announcement.

All libs are packaged separatly now...

All libs are packaged separately now, at each KDE release. This is why libraries are not included into the digiKam tarball.

kipi-plugins still released into digiKam tarball anyway.

Digikam for Kubuntu 15.10

Digikam (it's only 14.12) crashes in the brandnew 15.10 release from Kubuntu. The error is: symbol lookup error: /usr/lib/libkexiv2.so.11: undefined symbol: _ZN5Exiv213XmpProperties10registerNsERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES8_
I know such an error came up in earlier releases of Kubuntu and Philip created a ppa, and then it was solved. Will Philip provide a ppa for wily?
Thanks so much for the great work you are doing with digikam!

when you upgraded to ubuntu

when you upgraded to ubuntu 15.10 digikam must have changed so what you have installed doesn't match when it comes to digikam and libkexiv2. check so the installed packages come from the same source, ie not my PPA and then the official ubuntu source for digikam wily packages.

Yes I will provide digikam packages for wily too and hopefully give back geolocation support in digikam as it's disabled in official digikam packages for wily due to changes in how the marble packages are built that digikam use for geolocation and map features. My priority right now is to get working digikam 5 beta packages ready to be released when official digikam 5 beta1 is released then I will make digikam 4.14 for wily but that will be in a week or so.

/Philip

libkgeomap

Where can I download libkgeomap from ?

Almost all the link are broken or outdated.

All libs are in KDE download repository...

http://download.kde.org/stable/applications/15.08.2/src/

I had a similar problem after

I had a similar problem after installing the vivid version from the ppa then uninstalling to go back to the Kubuntu universe packages. I found that there were several packages from the ppa that I had to manually downgrade. (used "apt list --installed | grep vivid" to find them)

change geolocalisation of a picture

Hi, thank you for digikam, it's a great software I'm using all the time.

I'm using Digikam 4.13.0 with fedora 22. I can't find the way to change the geolocalisation (lat/lng) for a picture anymore. Did it disappear from digikam?

no...

No... geolocation is optional at compilation time. Sound like a problem with Fedora packages

The problem with the latest

The problem with the latest releases of linux distributions like Fedora 22 and ubuntu 15.10 is that they package and build Marble (which is a KDE framework that Digikam uses for the geolocation and map feature) based on QT5 and Digikam 4.x doesn't work with QT5 but QT4 which previous versions of Linux distribution have been using. This will instead work better with coming Digikam 5. That's why geolocation have been disabled in those new versions of Linux distributions and Digkam 4.x.

I agree with the comment

I agree with the comment here. For 4.x, you should have bundled all the libraries as you had been doing in the last releases. I fail to see what benefit you got by dropping those libraries, in the so called last 4.x stable release.

For Debian, I'm still waiting for libkface to enter unstable, and my guess is that it is being held off for similar reasons.

please where is the version

please where is the version for x64 windows?

nowhere... Digikam is mostly

nowhere... Digikam is mostly for users of Ubuntu.

"Be careful as digiKam is not as stable under Windows as under Linux because of some bugs in the underlying KDE SC libraries that digiKam depends on."

*Ubuntu->Linux

*Ubuntu->Linux

Dear Digikam team, It appears

Dear Digikam team,

It appears that this anonymous user is right, Digikam is not for Windows users!
Should we (all the windows users) consider this as the new strategy of the Development team: only have linux versions. In that case, just let us know and we will look for another software!

Regards.

Hi All, I'm using Digikam

Hi All,
I'm using Digikam 4.12.0 on Windows 7 and it works excellent. I guess we just have to be a bit patient for further Windows updates which is not really a serious problem, isn't it?
All the best.

Sorry, but Windows users are screwed ....

The one thing that I liked about Open Source projects, like this; gave Windows users access to freely published software. Which breaks the Oh So Old, Micro-Monopoly. Sorry to say, but it looks like your going to have to go back to the paid software like Photoshop again.

Mac Version Update

I've been trying the Mac version 4.13.0 for Yosemite quite a bit recently and its working great. I have 21,000 photos and have not had a crash after many imports the last day. There are a couple things not perfect, but those seem to be minor and overall it is really looking good. I do have good backups just incase. There is a big difference in stability from just a few versions ago (probably due to the upgraded exiv2 library). I've reported one bug and will do a few more. I'm hoping to switch out of Aperture (will need to eventually) soon and come back go Digikam.

It appears that the dev intend to work towards better Mac and Windows versions. Going forward It would be appreciated if the dev could better communicate to us users what the status of these builds are for Mac and Windows, and what the timeframe is for upgrades. Will this the support for Mac still be coming in the 5.0 version? Will there be a specific El Cap version - or does anyone know if the Yosemite version works fine on El Cap?

Thanks, Geoff

It take a while to make MAC version...

Compiling MAC/OSX PKG take a while, due to huge changes in Macports to support Qt4 and Qt5 at the same time.

PKG will be available when all will be tested and verified. Not before. It's the rules.

For Windows, packaging is delegate to a developer who is busy currently. You must be patient....

Support for NIKON D3300 (raw files)

Hi all,
first of all, thank you very much for the excellent software you are developing.
I have a question about my new Nikon D3300; I have currently Digikam 4.14.0 on Ubuntu 14.04, and it looks like my camera raw files are still not supported. I use to install updates from Philip Johnsson's PPA.
Do I have to wait for new release 5.0?
Thanks a lot for the precious help, and I wish you all the best.

Guido

Check libkdcraw/libraw...

Libraw is digiKam Raw decoder. You must update this library to have last camera support. 0.17 support this Nikon camera.

http://www.libraw.org/news/libraw-0-17

Note : digiKam 4.14.0 use libkdcraw interface to play with libraw. digiKam do not use libraw directly. You must update this library too...